Τώρα είναι Κυρ 21 Απρ 2019 07:40 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Πέμ 24 Ιούλ 2008 10:20 am 
Χωρίς σύνδεση

Εγγραφή: Κυρ 12 Οκτ 2003 01:52 am
Δημοσιεύσεις: 189
Τοποθεσία: ΝΙΚΑΙΑ - ΠΕΙΡΑΙΑΣ
Syntax: [ Download ] [ Hide ]
! ===================================================================================================
! ΗΜΕΡΗΣΙΟ - ΙΟΥΛΙΟΣ 2007 - ΘΕΜΑ 3
! ===================================================================================================
!  Το κλασικό παιχνίδι "Πέτρα-Ψαλίδι-Χαρτί" παίζεται με δυο παίκτες. Σε κάθε γύρο του παιχνιδιού,
!  ο κάθε παίκτης επιλέγει ένα από τα ΠΕΤΡΑ, ΨΑΛΙΔΙ, ΧΑΡΤΙ, και παρουσιάζει την επιλογή του
!  ταυτόχρονα με τον αντίπαλο του. Η ΠΕΤΡΑ κερδίζει το ΨΑΛΙΔΙ, το ΨΑΛΙΔΙ το ΧΑΡΤΙ και το ΧΑΡΤΙ την
!  ΠΕΤΡΑ. Σε περίπτωση που οι δυο παίκτες έχουν την ίδια επιλογή, ο γύρος λήγει ισόπαλος.
!  Το παιχνίδι προχωράει με συνεχόμενους γύρους μέχρι ένας τουλάχιστον από τους παίκτες να αποχωρήσει
!  Νικητής αναδεικνύεται ο παίκτης με τις περισσότερες νίκες. Αν οι δυο παίκτες έχουν τον ίδιο αριθμό
!  νικών, το παιχνίδι λήγει ισόπαλο.
!  Να αναπτύξετε αλγόριθμο ο οποίος διαβάζει τα ονόματα των δυο παικτών και υλοποιεί το παραπάνω
!  παιχνίδι ως εξής:
!  Α. Για κάθε γύρο του παιχνιδιού:
!    1.  διαβάζει την επιλογή κάθε παίκτη, η οποία μπορεί να είναι μία από τις εξής:
!        ΠΕΤΡΑ, ΨΑΛΙΔΙ, ΧΑΡΤΙ, ΤΕΛΟΣ. (Δεν απαιτείται έλεγχος εγκυρότητας τιμών.)
!    2.  συγκρίνει τις επιλογές των παικτών και διαπιστώνει το νικητή του γύρου ή την ισοπαλία.
!  Β. Τερματίζει το παιχνίδι όταν ένας τουλάχιστον από τους δυο παίκτες επιλέξει ΤΕΛΟΣ.
!  Γ. Εμφανίζει το όνομα του νικητή ή, αν δεν υπάρχει νικητής, το μήνυμα "ΤΟ ΠΑΙΧΝΙΔΙ ΕΛΗΞΕ ΙΣΟΠΑΛΟ".
! ===================================================================================================

ΠΡΟΓΡΑΜΜΑ  HMER_JUL_2007_03
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: s1 , s2
  ΧΑΡΑΚΤΗΡΕΣ: name1 , name2 , a1 , a2
ΑΡΧΗ
  ΓΡΑΨΕ 'Δώσε τα ονόματα των παικτών'
  ΔΙΑΒΑΣΕ name1 , name2
  s1 <-- 0
  s2 <-- 0

  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ 'Δώσε την επιλογή του παίκτη' , name1
    ΔΙΑΒΑΣΕ a1
    ΓΡΑΨΕ 'Δώσε την επιλογή του παίκτη' , name2
    ΔΙΑΒΑΣΕ a2

    ΑΝ a1 <> 'ΤΕΛΟΣ' ΚΑΙ a2 <> 'ΤΕΛΟΣ' ΤΟΤΕ

      ΑΝ a1 = 'ΠΕΤΡΑ' ΤΟΤΕ
        ΑΝ a2 = 'ΨΑΛΙΔΙ' ΤΟΤΕ
          s1 <-- s1 + 1
        ΑΛΛΙΩΣ_ΑΝ a2 = 'ΧΑΡΤΙ' ΤΟΤΕ
          s2 <-- s2 + 1
        ΤΕΛΟΣ_ΑΝ
      ΑΛΛΙΩΣ_ΑΝ a1 = 'ΨΑΛΙΔΙ' ΤΟΤΕ
        ΑΝ a2 = 'ΧΑΡΤΙ' ΤΟΤΕ
          s1 <-- s1 + 1
        ΑΛΛΙΩΣ_ΑΝ a2 = 'ΠΕΤΡΑ' ΤΟΤΕ
          s2 <-- s2 + 1
        ΤΕΛΟΣ_ΑΝ
      ΑΛΛΙΩΣ
        ΑΝ a2 = 'ΠΕΤΡΑ' ΤΟΤΕ
          s1 <-- s1 + 1
        ΑΛΛΙΩΣ_ΑΝ a2 = 'ΨΑΛΙΔΙ' ΤΟΤΕ
          s2 <-- s2 + 1
        ΤΕΛΟΣ_ΑΝ
      ΤΕΛΟΣ_ΑΝ

    ΤΕΛΟΣ_ΑΝ

  ΜΕΧΡΙΣ_ΟΤΟΥ a1 = 'ΤΕΛΟΣ' ή a2 = 'ΤΕΛΟΣ'

  ΑΝ s1 > s2 ΤΟΤΕ
    ΓΡΑΨΕ 'Νικητής είναι ο' , name1
  ΑΛΛΙΩΣ_ΑΝ s2 > s1 ΤΟΤΕ
    ΓΡΑΨΕ 'Νικητής είναι ο' , name2
  ΑΛΛΙΩΣ
    ΓΡΑΨΕ 'To παιχνίδι έληξε ισόπαλο'
  ΤΕΛΟΣ_ΑΝ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ                  
 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters