Τώρα είναι Δευτ 17 Φεβ 2020 04:00 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Εσπερινό - Θέμα 3
ΔημοσίευσηΔημοσιεύτηκε: Παρ 08 Ιουν 2007 12:51 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 12 Οκτ 2003 01:52 am
Δημοσιεύσεις: 189
Τοποθεσία: ΝΙΚΑΙΑ - ΠΕΙΡΑΙΑΣ
Syntax: [ Download ] [ Hide ]
! ===============================================================================================
! ΕΣΠΕΡΙΝΟ - ΙΟΥΝΙΟΣ 2007 - ΘΕΜΑ 3
! ===============================================================================================
! Μία εταιρεία ασφάλισης οχημάτων καθορίζει το ετήσιο κόστος ασφάλισης ανά τύπο οχήματος (δίκυκλο
! ή αυτοκίνητο) και κυβισμό, συμφωνά με τους παρακάτω πίνακες:
!     ----------------------------------------------------------------------------------------
!     |                  ΔΙΚΥΚΛΟ                |                  ΑΥΤΟΚΙΝΗΤΟ                |
!     ----------------------------------------------------------------------------------------
!     |     Κυβισμός        |  Κόστος Ασφάλισης |      Κυβισμός         | Κόστος Ασφάλισης   |
!     |(σε κυβικά εκατοστά) |    (σε ευρώ)      | (σε κυβικά εκατοστά)  |     (σε ευρώ)      |
!     ----------------------------------------------------------------------------------------
!     |   έως και 125       |      100          |     έως και 1400      |        400         |
!     |   πάνω από 125      |      140          | από 1401 έως και 1800 |        500         |
!     |                     |                   |     πάνω από 1800     |        700         |
!     ----------------------------------------------------------------------------------------
! Αν η ηλικία του οδηγού είναι από 18 έως και 24 ετών τότε το κόστος της ασφάλισης του οχήματος
! προσαυξάνεται κατά 10 % .
! Να αναπτύξετε αλγόριθμο, ο οποίος:
!  α. Να διαβάζει την ηλικία ενός οδηγού, τον τύπο του οχήματος και τον κυβισμό του, ελέγχοντας
!     ώστε ο τύπος του οχήματος να είναι "ΔΙΚΥΚΛΟ" ή "ΑΥΤΟΚΙΝΗΤΟ".
!  β. Να υπολογίζει και να εμφανίζει το ετήσιο κόστος ασφάλισης του οχήματος.
!
! Σημείωση: Να θεωρήσετε ότι η ηλικία του οδηγού είναι τουλάχιστον 18 ετών.
! ===============================================================================================

ΠΡΟΓΡΑΜΜΑ  ES_2007_3
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ : age , v
  ΧΑΡΑΚΤΗΡΕΣ : t
  ΠΡΑΓΜΑΤΙΚΕΣ : asf
ΑΡΧΗ
  ΓΡΑΨΕ 'Δώσε την ηλικία του οδηγού'
  ΔΙΑΒΑΣΕ age
  ΓΡΑΨΕ 'Δώσε τον τύπο του οχήματος'
  ΔΙΑΒΑΣΕ t
  ΟΣΟ t <> 'ΔΙΚΥΚΛΟ' ΚΑΙ t <> 'ΑΥΤΟΚΙΝΗΤΟ' ΕΠΑΝΑΛΑΒΕ
    ΓΡΑΨΕ 'Λάθος. Ξαναδώσε (ΔΙΚΥΚΛΟ ή ΑΥΤΟΚΙΝΗΤΟ)'
    ΔΙΑΒΑΣΕ t
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ 'Πόσα κυβικά είναι;'
  ΔΙΑΒΑΣΕ v
  ΑΝ t = 'ΔΙΚΥΚΛΟ' ΤΟΤΕ
    ΑΝ v <= 125 ΤΟΤΕ
      asf <-- 100
    ΑΛΛΙΩΣ
      asf <-- 140
    ΤΕΛΟΣ_ΑΝ
  ΑΛΛΙΩΣ
    ΑΝ v <= 1400 ΤΟΤΕ
      asf <-- 400
    ΑΛΛΙΩΣ_ΑΝ v <= 1800 ΤΟΤΕ
      asf <-- 500
    ΑΛΛΙΩΣ
      asf <-- 700
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΑΝ
  ΑΝ age <= 24 ΤΟΤΕ                                
    asf <-- asf + asf*10/100
  ΤΕΛΟΣ_ΑΝ
  ΓΡΑΨΕ 'Ετήσια ασφάλιστρα', asf , 'EURO'
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
Προβολές σελίδων: website counters