Ασκησιολόγιο ΓλωσσοΜάθειας
http://www.spinet.gr/glossomatheia/programs/

Εσπερινό - Θέμα 2Α
http://www.spinet.gr/glossomatheia/programs/viewtopic.php?f=30&t=573
Σελίδα 1 από 1

Συγγραφέας:  ΧΑΤΖΗΤΣΟΜΠΑΝΗΣ ΘΕΟΦΙΛΟΣ [ Παρ 08 Ιουν 2007 12:38 pm ]
Θέμα δημοσίευσης:  Εσπερινό - Θέμα 2Α

Syntax: [ Download ] [ Hide ]
! ===============================================================================================
! ΕΣΠΕΡΙΝΟ - ΙΟΥΝΙΟΣ 2007 - ΘΕΜΑ 2α
! ===============================================================================================
! Δίνεται το παρακάτω τμήμα αλγορίθμου:
!   Χ <-- 2
!   ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
!     Υ <-- Χ DIV 2
!     Ζ <-- Α_Μ(Χ/3)
!     ΑΝ Ζ > 0 ΤΟΤΕ
!       Α <-- Ζ
!     ΑΛΛΙΩΣ
!       Α <-- Υ
!     ΤΕΛΟΣ_ΑΝ
!     ΓΡΑΨΕ Χ , Υ , Ζ , Α
!     Χ <-- Χ+3
!   ΜΕΧΡΙΣ_ΟΤΟΥ Χ > 10
!
! Να γράψετε στο τετράδιο σας τις τιμές των μεταβλητών που θα εμφανιστούν σε κάθε επανάληψη
! ===============================================================================================

ΠΡΟΓΡΑΜΜΑ  ES_2007_02a
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ : Χ , Υ , Ζ , Α
ΑΡΧΗ
  Χ <-- 2
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    Υ <-- Χ DIV 2
    Ζ <-- Α_Μ(Χ/3)
    ΑΝ Ζ > 0 ΤΟΤΕ
      Α <-- Ζ
    ΑΛΛΙΩΣ
      Α <-- Υ
    ΤΕΛΟΣ_ΑΝ
    ΓΡΑΨΕ Χ , Υ , Ζ , Α
    Χ <-- Χ + 3
  ΜΕΧΡΙΣ_ΟΤΟΥ Χ > 10
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Σελίδα 1 από 1 Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]
Powered by phpBB® Forum Software © phpBB Group
http://www.phpbb.com/