Τώρα είναι Δευτ 28 Σεπ 2020 06:05 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Εσπερινό - Θέμα 2Β
ΔημοσίευσηΔημοσιεύτηκε: Παρ 08 Ιουν 2007 12:39 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 12 Οκτ 2003 01:52 am
Δημοσιεύσεις: 189
Τοποθεσία: ΝΙΚΑΙΑ - ΠΕΙΡΑΙΑΣ
Syntax: [ Download ] [ Hide ]
! ===============================================================================================
! ΕΣΠΕΡΙΝΟ - ΙΟΥΝΙΟΣ 2007 - ΘΕΜΑ 2β
! ===============================================================================================
! Δίνεται το παρακάτω τμήμα αλγορίθμου:
!   Χ <-- 2
!   ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
!     Υ <-- Χ DIV 2
!     Ζ <-- Α_Μ(Χ/3)
!     ΑΝ Ζ > 0 ΤΟΤΕ
!       Α <-- Ζ
!     ΑΛΛΙΩΣ
!       Α <-- Υ
!     ΤΕΛΟΣ_ΑΝ
!     ΓΡΑΨΕ Χ , Υ , Ζ , Α
!     Χ <-- Χ+3
!   ΜΕΧΡΙΣ_ΟΤΟΥ Χ > 10
!
! Να μετατρέψετε το παραπάνω τμήμα αλγορίθμου σε ισοδύναμο με χρήση της δομής επανάληψης
! ΓΙΑ...ΑΠΟ...ΜΕΧΡΙ...ΜΕ_ΒΗΜΑ.
! ===============================================================================================

ΠΡΟΓΡΑΜΜΑ  ES_2007_02b
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ : Χ , Υ , Ζ , Α
ΑΡΧΗ
  ΓΙΑ Χ ΑΠΟ 2 ΜΕΧΡΙ 10 ΜΕ ΒΗΜΑ 3
    Υ <-- Χ DIV 2
    Ζ <-- Α_Μ(Χ/3)
    ΑΝ Ζ > 0 ΤΟΤΕ
      Α <-- Ζ
    ΑΛΛΙΩΣ
      Α <-- Υ
    ΤΕΛΟΣ_ΑΝ
    ΓΡΑΨΕ Χ , Υ , Ζ , Α
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση: Δεν υπάρχουν εγγεγραμμένα μέλη και 2 επισκέπτες


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters