Τώρα είναι Παρ 10 Απρ 2020 11:48 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 4 Δημοσιεύσεις ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Ημερήσιο - Θέμα 4
ΔημοσίευσηΔημοσιεύτηκε: Πέμ 31 Μάιος 2007 04:18 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 12 Οκτ 2003 01:52 am
Δημοσιεύσεις: 189
Τοποθεσία: ΝΙΚΑΙΑ - ΠΕΙΡΑΙΑΣ
Syntax: [ Download ] [ Hide ]
! ===============================================================================================
! ΗΜΕΡΗΣΙΟ - ΜΑΙΟΣ 2007 - ΘΕΜΑ 4
! ===============================================================================================
! Μια δισκογραφική εταιρεία καταγράφει στοιχεία για ένα έτος για κάθε ένα από τα 20 CDs που
! κυκλοφόρησε. Τα στοιχεία αυτά είναι ο τίτλος του CD, ο τύπος της μουσικής που περιέχει και
! οι μηνιαίες του πωλήσεις (ποσά σε ευρώ) στη διάρκεια του έτους.
! Οι τύποι μουσικής είναι δύο: «ορχηστρική» και «φωνητική».
! Να αναπτυχθεί αλγόριθμος ο οποίος :
! Για κάθε ένα από τα 20 CDs, να διαβάζει τον τίτλο, τον τύπο της μουσικής και τις πωλήσεις του
! για κάθε μήνα, ελέγχοντας την έγκυρη καταχώριση του τύπου της μουσικής.
! Να εμφανίζει τον τίτλο ή τους τίτλους των CDs με τις περισσότερες πωλήσεις τον 3° μήνα του έτους.
! Να εμφανίζει τους τίτλους των ορχηστρικών CDs με ετήσιο σύνολο πωλήσεων τουλάχιστον 5000 ευρώ.
! Να εμφανίζει πόσα από τα CDs είχαν σύνολο πωλήσεων στο δεύτερο εξάμηνο μεγαλύτερο απ ό,τι στο
! πρώτο.
! ===============================================================================================
!
ΠΡΟΓΡΑΜΜΑ ΗΜ_2007_05_4
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ : i , j , n
  ΠΡΑΓΜΑΤΙΚΕΣ: πωλ[20,12] , max , s , s1 , s2
  ΧΑΡΑΚΤΗΡΕΣ : t[20] , m[20]
ΑΡΧΗ
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 20
    ΓΡΑΨΕ 'Δώσε τον τίτλο του CD No :', i
    ΔΙΑΒΑΣΕ t[i]
    ΓΡΑΨΕ 'Δώσε τον τύπο της μουσικής που περιέχει.'
    ΔΙΑΒΑΣΕ m[i]
    ΟΣΟ m[i] <> 'ορχηστρική' ΚΑΙ m[i] <> 'φωνητική' ΕΠΑΝΑΛΑΒΕ
      ΓΡΑΨΕ 'Λάθος. Ξαναδώσε'
      ΔΙΑΒΑΣΕ m[i]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 12
      ΓΡΑΨΕ 'Τί πωλήσεις έκανε το CD κατά το μήνα', j ,';'
      ΔΙΑΒΑΣΕ πωλ[i,j]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  max <-- 0
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 20
    ΑΝ πωλ[i,3] > max ΤΟΤΕ
      max <-- πωλ[i,3]
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ 'Τον 3ο μήνα του έτους έκαναν μεγαλύτερες πωλήσεις τα :'
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 20
    ΑΝ πωλ[i,3] = max ΤΟΤΕ
      ΓΡΑΨΕ t[i]
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ 'Τα ορχηστρικά CD με ετήσιες πωλήσεις τουλάχιστον 5.000 ευρώ είναι τα :'
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 20
    s <-- 0
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 12
      s <-- s + πωλ[i,j]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΑΝ s >= 5000 ΤΟΤΕ
      ΓΡΑΨΕ t[i]
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  n <-- 0
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 20
    s1 <-- 0
    s2 <-- 0
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 6
      s1 <-- s1 + πωλ[i,j]
      s2 <-- s2 + πωλ[i,j+6]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ                      
    ΑΝ s2 > s1 ΤΟΤΕ
      n <-- n + 1
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ n , 'CDs έκαναν μαγαλύτερες πωλήσεις το δεύτερο εξάμηνο σε σχέση με το πρώτο.'

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


Τελευταία επεξεργασία από ΧΑΤΖΗΤΣΟΜΠΑΝΗΣ ΘΕΟΦΙΛΟΣ και Τρί 10 Ιούλ 2007 03:15 pm, έχει επεξεργασθεί 1 φορά/ες συνολικά

Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης:
ΔημοσίευσηΔημοσιεύτηκε: Δευτ 04 Ιουν 2007 02:05 pm 
Χωρίς σύνδεση

Εγγραφή: Σάβ 04 Νοέμ 2006 01:07 am
Δημοσιεύσεις: 20
Θεωρω οτι ήταν αρκετα δυσκολο το θεμα φετος...

_________________
Δίνεις Πανελλαδικές εξετάσεις ???

Τότε έλα στο http://www.glyk.co.nr -> ένα φόρουμ για μαθητές Γ Λυκείου


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης:
ΔημοσίευσηΔημοσιεύτηκε: Τρί 10 Ιούλ 2007 12:23 am 
Χωρίς σύνδεση

Εγγραφή: Σάβ 04 Νοέμ 2006 01:07 am
Δημοσιεύσεις: 20
Μαλλον εδω υπαρχει καποιο λαθος...

Syntax: [ Download ] [ Hide ]
ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 12
    ΑΝ πωλ[i,3] > max ΤΟΤΕ
      max <-- πωλ[i,3]
    ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ




Το σωστο:

Syntax: [ Download ] [ Hide ]
ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 20
    ΑΝ πωλ[i,3] > max ΤΟΤΕ
      max <-- πωλ[i,3]
    ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

_________________
Δίνεις Πανελλαδικές εξετάσεις ???

Τότε έλα στο http://www.glyk.co.nr -> ένα φόρουμ για μαθητές Γ Λυκείου


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης:
ΔημοσίευσηΔημοσιεύτηκε: Τρί 10 Ιούλ 2007 03:13 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 12 Οκτ 2003 01:52 am
Δημοσιεύσεις: 189
Τοποθεσία: ΝΙΚΑΙΑ - ΠΕΙΡΑΙΑΣ
Σωστή η παρατήρηση. Ναι όντως είναι λάθος. Καμιά φορά κάνοντας copy και paste μερικά κομμάτια του κώδικα (και αν δεν προσέχεις και λίγο) ξεφεύγουν μερικά λάθη.
Σε ευχαριστώ για την παρατήρηση.
Θα διορθώσω και το αρχικό ώστε όποιος το πάρει στο μέλλον να είναι σωστό.


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 4 Δημοσιεύσεις ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
Προβολές σελίδων: website counters