Τώρα είναι Δευτ 28 Σεπ 2020 07:18 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Ημερήσιο - Θέμα 3
ΔημοσίευσηΔημοσιεύτηκε: Πέμ 31 Μάιος 2007 04:17 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 12 Οκτ 2003 01:52 am
Δημοσιεύσεις: 189
Τοποθεσία: ΝΙΚΑΙΑ - ΠΕΙΡΑΙΑΣ
Syntax: [ Download ] [ Hide ]
! ===============================================================================================
! ΗΜΕΡΗΣΙΟ - ΜΑΙΟΣ 2007 - ΘΕΜΑ 3
! ===============================================================================================
! Ένας συλλέκτης γραμματοσήμων επισκέπτεται στο διαδίκτυο το αγαπημένο του ηλεκτρονικό κατάστημα
! φιλοτελισμού προκειμένου να αγοράσει γραμματόσημα. Προτίθεται να ξοδέψει μέχρι 1500 ευρώ.
! Να αναπτύξετε αλγόριθμο ο οποίος:
! α. Για κάθε γραμματόσημο, να διαβάζει την τιμή και την προέλευση του (ελληνικό/ξένο) και
!    να επιτρέπει την αγορά του, εφόσον η τιμή του δεν υπερβαίνει το διαθέσιμο υπόλοιπο χρημάτων.
!    Διαφορετικά να τερματίζει τυπώνοντας το μήνυμα «ΤΕΛΟΣ ΑΓΟΡΩΝ».
!    ΣΗΜΕΙΩΣΗ : Δεν απαιτείται έλεγχος εγκυρότητας για τα δεδομένα εισόδου.
! β. Να τυπώνει:
!    1. Το συνολικό ποσό που ξόδεψε ο συλλέκτης.
!    2. Το πλήθος των ελληνικών και το πλήθος των ξένων γραμματοσήμων που αγόρασε.
!    3. Το ποσό που περίσσεψε, εφόσον υπάρχει, διαφορετικά το μήνυμα «ΕΞΑΝΤΛΗΘΗΚΕ ΟΛΟ ΤΟ ΠΟΣΟ».
! ===============================================================================================
!
ΠΡΟΓΡΑΜΜΑ ΗΜ_2007_05_3
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ : x , n1 , n2
  ΠΡΑΓΜΑΤΙΚΕΣ: ποσο , τιμη , s
  ΛΟΓΙΚΕΣ: flag
ΑΡΧΗ
  ποσο <-- 1500
  s <-- 0
  n1 <-- 0
  n2 <-- 0
  flag <-- αληθής                           ! ΘΑ ΑΓΟΡΑΣΤΕΙ ΚΑΙ ΑΛΛΟ ΓΡΑΜΜΑΤΟΣΗΜΟ
  ΟΣΟ flag = αληθής ΕΠΑΝΑΛΑΒΕ
    ΓΡΑΨΕ 'Δώσε τιμή γραμματοσήμου'
    ΔΙΑΒΑΣΕ τιμή
    ΑΝ s + τιμη <= ποσο ΤΟΤΕ
      s <-- s + τιμη
      ΓΡΑΨΕ '1. ΕΛΛΗΝΙΚΟ ή 2. ΞΕΝΟ ;'                                                            
      ΔΙΑΒΑΣΕ x
      ΑΝ x = 1 ΤΟΤΕ
        n1 <-- n1 + 1
      ΑΛΛΙΩΣ
        n2 <-- n2 + 1
      ΤΕΛΟΣ_ΑΝ
    ΑΛΛΙΩΣ
      flag <-- ψευδής
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ 'ΤΕΛΟΣ ΑΓΟΡΩΝ'
  ΓΡΑΨΕ 'Το συνολικό ποσό που δαπανήθηκε είναι ίσο με' , s , 'ευρώ.'
  ΓΡΑΨΕ 'Αγοράσθηκαν' , n1 , 'ξένα και' , n2 , 'ελληνικά γραμματόσημα.'
  ΑΝ s = ποσο ΤΟΤΕ
    ΓΡΑΨΕ 'ΕΞΑΝΤΛΗΘΗΚΕ ΟΛΟ ΤΟ ΠΟΣΟ'
  ΑΛΛΙΩΣ
    ΓΡΑΨΕ 'Περίσσεψαν' , ποσο - s , 'ευρώ.'
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση: Δεν υπάρχουν εγγεγραμμένα μέλη και 2 επισκέπτες


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters