Ασκησιολόγιο ΓλωσσοΜάθειας
http://www.spinet.gr/glossomatheia/programs/

Ημερήσιο - Θέμα 2Β
http://www.spinet.gr/glossomatheia/programs/viewtopic.php?f=30&t=564
Σελίδα 1 από 1

Συγγραφέας:  ΧΑΤΖΗΤΣΟΜΠΑΝΗΣ ΘΕΟΦΙΛΟΣ [ Πέμ 31 Μάιος 2007 03:31 pm ]
Θέμα δημοσίευσης:  Ημερήσιο - Θέμα 2Β

Syntax: [ Download ] [ Hide ]
! ===============================================================================================
! ΗΜΕΡΗΣΙΟ - ΜΑΙΟΣ 2007 - ΘΕΜΑ 2Β  
! ===============================================================================================
! Δίνεται παρακάτω ένα πρόγραμμα καιένα υποπρόγραμμα :
!
! ΠΡΟΓΡΑΜΜΑ Υπολογισμοί
! ΜΕΤΑΒΛΗΤΕΣ
!  ΠΡΑΓΜΑΤΙΚΕΣ : α, β, γ
! ΑΡΧΗ
! ΔΙΑΒΑΣΕ α , β
!   γ <-- α + Πράξη(α,β)
!   ΓΡΑΨΕ γ
! ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
!
! ΣΥΝΑΡΤΗΣΗ Πράξη(χ,ψ): ΠΡΑΓΜΑΤΙΚΗ
! ΜΕΤΑΒΛΗΤΕΣ
!   ΠΡΑΓΜΑΤΙΚΕΣ : χ, ψ
! ΑΡΧΗ
! ΑΝ χ >= ψ ΤΟΤΕ
!   Πράξη <-- χ &#8211; ψ
! ΑΛΛΙΩΣ
!    Πράξη <-- χ + ψ
!   ΤΕΛΟΣ_ΑΝ
! ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ
!
! Να ξαναγράψετε το πρόγραμμα, ώστε να επιτελεί την ίδια λειτουργία χωρίς χρήση υποπρογράμματος.
! ===============================================================================================
!
ΠΡΟΓΡΑΜΜΑ ΗΜ_2007_05_2Β
ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ: α, β, γ
ΑΡΧΗ
  ΔΙΑΒΑΣΕ α , β
  ΑΝ α >= β ΤΟΤΕ
    γ <-- 2*α - β
  ΑΛΛΙΩΣ
    γ <-- 2*α + β            
  ΤΕΛΟΣ_ΑΝ
  ΓΡΑΨΕ γ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 

Σελίδα 1 από 1 Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]
Powered by phpBB® Forum Software © phpBB Group
http://www.phpbb.com/