Ασκησιολόγιο ΓλωσσοΜάθειας
http://www.spinet.gr/glossomatheia/programs/

Ημερήσιο - Θέμα 1Γ
http://www.spinet.gr/glossomatheia/programs/viewtopic.php?f=30&t=562
Σελίδα 1 από 1

Συγγραφέας:  ΧΑΤΖΗΤΣΟΜΠΑΝΗΣ ΘΕΟΦΙΛΟΣ [ Πέμ 31 Μάιος 2007 03:06 pm ]
Θέμα δημοσίευσης:  Ημερήσιο - Θέμα 1Γ

Syntax: [ Download ] [ Hide ]
! ===============================================================================================
! ΗΜΕΡΗΣΙΟ - ΜΑΙΟΣ 2007 - ΘΕΜΑ 1Γ
! ===============================================================================================
! Δίνεται το παρακάτω τμήμα αλγορίθμου σε φυσική γλώσσα κατά βήματα
!
! Βήμα 1:  Αν Α > 0 τότε πήγαινε στο Βήμα 5
! Βήμα 2:  Αν Α = 0 τότε πήγαινε στο Βήμα 7
! Βήμα 3:  Τύπωσε “Αρνητικός’’
! Βήμα 4:  Πήγαινε στο Βήμα 8
! Βήμα 5:  Τύπωσε “Θετικός’’
! Βήμα 6:  Πήγαινε στο Βήμα 8
! Βήμα 7:  Τύπωσε “Μηδέν’’
! Βήμα 8:  Τύπωσε “Τέλος’’
!
! Να κωδικοποιήσετε το τμήμα του αλγορίθμου σε ψευδογλώσσα σύμφωνα με τις αρχές του δομημένου
! προγραμματισμού.
! ===============================================================================================
!
ΠΡΟΓΡΑΜΜΑ ΗΜ_2007_05_1Γ
ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ: Α
ΑΡΧΗ
  ΔΙΑΒΑΣΕ Α
  ΑΝ Α > 0 ΤΟΤΕ               ! Το ΔΙΑΒΑΣΕ Α δε χρειάζεται να γραφεί αφού δεν υπάρχει στο τμήμα
    ΓΡΑΨΕ 'Θετικός'           ! αλγορίθμού που έχει δοθεί και ζητείται και πάλι τμήμα αλγορίθμου
  ΑΛΛΙΩΣ_ΑΝ Α = 0 ΤΟΤΕ        ! και όχι ολοκληρωμένος αλγόριθμος.
    ΓΡΑΨΕ 'Μηδέν'
  ΑΛΛΙΩΣ
    ΓΡΑΨΕ 'Αρνητικός'
  ΤΕΛΟΣ_ΑΝ
  ΓΡΑΨΕ 'Τέλος'
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Σελίδα 1 από 1 Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]
Powered by phpBB® Forum Software © phpBB Group
http://www.phpbb.com/