Τώρα είναι Τρί 18 Φεβ 2020 01:21 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Ημερήσιο - Θέμα 2Α
ΔημοσίευσηΔημοσιεύτηκε: Πέμ 31 Μάιος 2007 03:29 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 12 Οκτ 2003 01:52 am
Δημοσιεύσεις: 189
Τοποθεσία: ΝΙΚΑΙΑ - ΠΕΙΡΑΙΑΣ
Syntax: [ Download ] [ Hide ]
! ===============================================================================================
! ΗΜΕΡΗΣΙΟ - ΜΑΙΟΣ 2007 - ΘΕΜΑ 2Α
! ===============================================================================================
! Δίνεται παρακάτω ένα πρόγραμμα καιένα υποπρόγραμμα :
!
! ΠΡΟΓΡΑΜΜΑ Υπολογισμοί
! ΜΕΤΑΒΛΗΤΕΣ
!  ΠΡΑΓΜΑΤΙΚΕΣ : α, β, γ
! ΑΡΧΗ
! ΔΙΑΒΑΣΕ α , β
!   γ <-- α + Πράξη(α,β)
!   ΓΡΑΨΕ γ
! ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
!
! ΣΥΝΑΡΤΗΣΗ Πράξη(χ,ψ): ΠΡΑΓΜΑΤΙΚΗ
! ΜΕΤΑΒΛΗΤΕΣ
!   ΠΡΑΓΜΑΤΙΚΕΣ : χ, ψ
! ΑΡΧΗ
! ΑΝ χ >= ψ ΤΟΤΕ                    
!   Πράξη <-- χ &#8211; ψ
! ΑΛΛΙΩΣ
!    Πράξη <-- χ + ψ
!   ΤΕΛΟΣ_ΑΝ
! ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ
!
! Να ξαναγράψετε το πρόγραμμα, ώστε να επιτελεί την ίδια λειτουργία χρησιμοποιώντας διαδικασία
! αντί συνάρτησης.
! ===============================================================================================
!
ΠΡΟΓΡΑΜΜΑ ΗΜ_2007_05_2Α
ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ: α, β, γ
ΑΡΧΗ
  ΔΙΑΒΑΣΕ α , β
  ΚΑΛΕΣΕ Πράξη(α , β , γ)
  γ <-- α + γ
  ΓΡΑΨΕ γ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

ΔΙΑΔΙΚΑΣΙΑ Πράξη(χ , ψ , ω)
ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ : χ , ψ , ω
ΑΡΧΗ
  ΑΝ χ >= ψ ΤΟΤΕ
    ω <-- χ - ψ
  ΑΛΛΙΩΣ
    ω <-- χ + ψ
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
Προβολές σελίδων: website counters