Τώρα είναι Τρί 31 Μαρ 2020 06:49 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Προσομοίωση - Θέμα 4
ΔημοσίευσηΔημοσιεύτηκε: Τετ 23 Μάιος 2007 11:36 am 
Χωρίς σύνδεση

Εγγραφή: Κυρ 12 Οκτ 2003 01:52 am
Δημοσιεύσεις: 189
Τοποθεσία: ΝΙΚΑΙΑ - ΠΕΙΡΑΙΑΣ
Syntax: [ Download ] [ Hide ]
!=================================================================================================
! ΠΡΟΣΟΜΟΙΩΣΗ 2007 - ΘΕΜΑ 4
!=================================================================================================
! Το 1988 στο πρωτάθλημα της FORMULA1 αποφασίστηκε ο τρόπος υπολογισμού της βαθμολογίας των οδηγών
! να είναι ο ακόλουθος : Αν και θα έπαιρναν μέρος σε 16 αγώνες, η κατάταξή τους θα κρινόταν από το
! άθροισμα των 11 καλύτερων βαθμολογιών τους.
! Να γραφεί αλγόριθμος ο οποίος :
!  Α) Καταχωρεί σε ένα μονοδιάστατο πίνακα τα ονόματα των 36 οδηγών που συμμετείχαν.
!  B) Καταχωρεί σε ένα δισδιάστατο πίνακα τη βαθμολογία των 36 οδηγών στους 16 αγώνες.
!  Γ) Ταξινομεί σε φθίνουσα σειρά τις βαθμολογίες καθενός από τους 36 οδηγούς.
!  Δ) Υπολογίζει τη συνολική βαθμολογία κάθε οδηγού αθροίζοντας τις 11 καλύτερες βαθμολογίες του.
!  Ε) Εμφανίζει το όνομα του πρωταθλητή ακολουθούμενο από τη συνολική βαθμολογία του.
!     Υποθέτουμε ότι δεν υπάρχει ισοβαθμία στην 1η θέση.
!=================================================================================================

ΠΡΟΓΡΑΜΜΑ PR_07_4
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ : b[36,16] , s[36] , i , j , k , temp , max , winner
  ΧΑΡΑΚΤΗΡΕΣ : name[36]
ΑΡΧΗ
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 36
    ΓΡΑΨΕ 'Δώσε το όνομα του οδηγού' , i
    ΔΙΑΒΑΣΕ name[i]
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 16
      ΓΡΑΨΕ 'Δώσε τη βαθμολογία του οδηγού', i , 'στον αγώνα', j
      ΔΙΑΒΑΣΕ b[i,j]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΙΑ k ΑΠΟ 1 ΜΕΧΡΙ 36
    ΓΙΑ i ΑΠΟ 2 ΜΕΧΡΙ 16
      ΓΙΑ j ΑΠΟ 16 ΜΕΧΡΙ i ΜΕ ΒΗΜΑ -1
        ΑΝ b[k,j-1] < b[k,j] ΤΟΤΕ
          temp <-- b[k,j-1]
          b[k,j-1] <-- b[k,j]
          b[k,j] <-- temp
        ΤΕΛΟΣ_ΑΝ
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 36
    s[i] <-- 0
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 11
      s[i] <-- s[i] + b[i,j]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  max <-- 0
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 36
    ΑΝ s[i] > max ΤΟΤΕ
      max <-- s[i]
      winner <-- i
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ 'ΝΙΚΗΤΗΣ O', name[winner] , 'ME', max , 'BAΘΜΟΥΣ.'

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters