Τώρα είναι Παρ 10 Απρ 2020 11:20 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Προσομοίωση - Θέμα 2
ΔημοσίευσηΔημοσιεύτηκε: Τετ 23 Μάιος 2007 11:32 am 
Χωρίς σύνδεση

Εγγραφή: Κυρ 12 Οκτ 2003 01:52 am
Δημοσιεύσεις: 189
Τοποθεσία: ΝΙΚΑΙΑ - ΠΕΙΡΑΙΑΣ
Syntax: [ Download ] [ Hide ]
! ===============================================================================================
! ΠΡΟΣΟΜΟΙΩΣΗ 2007 - ΘΕΜΑ 2
!================================================================================================
! Δίνεται το ακόλουθο πρόγραμμα :
!
! ΠΡΟΓΡΑΜΜΑ ΘΕΜΑ2
! ΜΕΤΑΒΛΗΤΕΣ
!   ΑΚΕΡΑΙΕΣ : i , j , Α , Β , D
! ΑΡΧΗ
!   Α <-- 4
!   Β <-- 10
!   ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 2
!     ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ i
!       ΚΑΛΕΣΕ ΔΙΑΔ(Α , Β)
!       Α <-- Α + 3
!       Β <-- Β - 4
!     ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
!   ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
!   D <-- Α DIV Β
!   ΓΡΑΨΕ d
! ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
!
! ΔΙΑΔΙΚΑΣΙΑ ΔΙΑΔ(Β , Γ)
! ΜΕΤΑΒΛΗΤΕΣ
!   ΑΚΕΡΑΙΕΣ : Α , Β , Γ
! ΑΡΧΗ
!   B <-- B + 1
!   A <-- A + 2
!   Γ <-- FUN(Γ , Α)
!   ΓΡΑΨΕ Α , Β , Γ
! ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ
!
! ΣΥΝΑΡΤΗΣΗ FUN( Χ , Υ) : ΑΚΕΡΑΙΑ
! ΜΕΤΑΒΛΗΤΕΣ                                                      
!   ΑΚΕΡΑΙΕΣ : Χ , Υ
! ΑΡΧΗ
!   FUN <-- Υ mod Χ
! ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ
!
! Να εκτελέσετε το παραπάνω πρόγραμμα και να γράψετε :
! Α. Τις τιμές των μεταβλητών Α , Β , Γ όπως αυτές εκτυπώνονται από τη διαδικασία σε κάθε επανάληψη.
! Β. Την τιμή της μεταβλητής D που εκτυπώνεται.
!
!================================================================================================

ΠΡΟΓΡΑΜΜΑ PR_07_2
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ : i , j , Α , Β , D
ΑΡΧΗ                          
  Α <-- 4
  Β <-- 10
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 2
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ i
      ΚΑΛΕΣΕ DIAD(Α , Β)
      Α <-- Α + 3
      Β <-- Β - 4
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  D <-- Α DIV Β
  ΓΡΑΨΕ D
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

! ---------------------------

ΔΙΑΔΙΚΑΣΙΑ DIAD(Β , Α)
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ : Α , Β , Γ
ΑΡΧΗ
  Β <-- Β + 1
  Α <-- Α + 2
  Γ <-- FUN(Α , Β)
  ΓΡΑΨΕ Α , Β , Γ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

! ---------------------------

ΣΥΝΑΡΤΗΣΗ FUN(x,y): ΑΚΕΡΑΙΑ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ : x , y
ΑΡΧΗ
  FUN <-- y MOD x
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
Προβολές σελίδων: website counters