Τώρα είναι Δευτ 17 Φεβ 2020 04:42 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Προσομοίωση - Θέμα 1Ε
ΔημοσίευσηΔημοσιεύτηκε: Τετ 23 Μάιος 2007 11:30 am 
Χωρίς σύνδεση

Εγγραφή: Κυρ 12 Οκτ 2003 01:52 am
Δημοσιεύσεις: 189
Τοποθεσία: ΝΙΚΑΙΑ - ΠΕΙΡΑΙΑΣ
Syntax: [ Download ] [ Hide ]
!================================================================================================
! ΠΡΟΣΟΜΟΙΩΣΗ 2007 - ΘΕΜΑ 1Ε
!================================================================================================
! Να γράψετε στο τετράδιό σας τους αριθμούς της στήλης Α και δίπλα το γράμμα της στήλης Β που
! αντιστοιχεί σωστά. Στη στήλη Β υπάρχει ένα επιπλέον στοιχείο.
!
!  Στήλη Α                                  Στήλη Β
!  Τμήμα αλγορίθμου                         Αριθμός επαναλήψεων
!  --------------------------------------   -------------------
!  1.  ΓΙΑ i ΑΠΟ 10 ΜΕΧΡΙ 9 ΜΕ_ΒΗΜΑ -0.1
!        ΕΜΦΑΝΙΣΕ x
!      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ                        Α.     0
!
!  2.  i <-- 1
!      k <-- 1                                 Β.     1
!      ΟΣΟ k <= 10 ΕΠΑΝΑΛΑΒΕ
!         i <-- i + 1
!      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ                        Γ.     9
!
!  3.  ΓΙΑ i ΑΠΟ -5 ΜΕΧΡΙ 4
!        ΕΜΦΑΝΙΣΕ "Ανάπτυξη Εφαρμογών"         Δ.    10
!      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
!
!  4.  i <-- 1                                 Ε.    11
!      ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
!        i <-- i + 1
!      ΜΕΧΡΙΣ_ΟΤΟΥ i > -1                     ΣΤ.  άπειρες
!
!  5.  k <-- 5
!      ΟΣΟ k <> 5 ΕΠΑΝΑΛΑΒΕ
!        k <-- k + 1
!      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
!================================================================================================

ΠΡΟΓΡΑΜΜΑ  PR_07_1E
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ : k
  ΠΡΑΓΜΑΤΙΚΕΣ : i
  ΧΑΡΑΚΤΗΡΕΣ: x
ΑΡΧΗ
  x <-- '***'
  ΓΡΑΨΕ '====== 1 ======='
  ΓΙΑ i ΑΠΟ 10 ΜΕΧΡΙ 9 ΜΕ ΒΗΜΑ -0.1   ! Μετρήστε το πόσες φορές εμφανίζεται
    ΓΡΑΨΕ x                           ! στην οθόνη το ***
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ                    ! Ο βρόχος εκτελείται 11 φορές.
  ΓΡΑΨΕ

  ΓΡΑΨΕ '====== 2 ======='
  i <-- 1
  k <-- 1
  ! ΟΣΟ k <= 10 ΕΠΑΝΑΛΑΒΕ             ! Βγάζοντας τα αρχικά θαυμαστικά
  !   i <-- i + 1                     ! γίνεται φανερό ότι προκύπτει
  ! ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ                  ! ατέρμων βρόχος.
  ΓΡΑΨΕ

  ΓΡΑΨΕ '====== 3 ======='            ! Μετρήστε το πόσες φορές εμφανίζεται
  ΓΙΑ i ΑΠΟ -5 ΜΕΧΡΙ 4                ! στην οθόνη το Ανάπτυξη Εφαρμογών.
    ΓΡΑΨΕ 'Ανάπτυξη Εφαρμογών'        ! Ο βρόχος εκτελείται 10 φορές.
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ

  ΓΡΑΨΕ '====== 4 ======='
  i <-- 1
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ                     ! Μετρήστε το πόσες φορές εμφανίζεται
    i <-- i + 1                       ! στην οθόνη το ***
    ΓΡΑΨΕ x                           ! Ο βρόχος εκτελείται 1 φορά.
  ΜΕΧΡΙΣ_ΟΤΟΥ i > -1
  ΓΡΑΨΕ

  ΓΡΑΨΕ '====== 5 ======='
  k <-- 5                             ! Παρατηρήστε ότι δεν εμφανίζεται
  ΟΣΟ k <> 5 ΕΠΑΝΑΛΑΒΕ                ! εμφανίζεται στην οθόνη το ***
    k <-- k + 1                       ! αν και μέσα στην επαναληπτική δομή
    ΓΡΑΨΕ x                           ! υπάρχει η εντολή ΓΡΑΨΕ x.
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ                    ! Ο βρόχος δεν εκτελείται καμία φορά.
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters