Ασκησιολόγιο ΓλωσσοΜάθειας
http://www.spinet.gr/glossomatheia/programs/

Προσομοίωση - Θέμα 1Δ
http://www.spinet.gr/glossomatheia/programs/viewtopic.php?f=30&t=555
Σελίδα 1 από 1

Συγγραφέας:  ΧΑΤΖΗΤΣΟΜΠΑΝΗΣ ΘΕΟΦΙΛΟΣ [ Τετ 23 Μάιος 2007 11:29 am ]
Θέμα δημοσίευσης:  Προσομοίωση - Θέμα 1Δ

Syntax: [ Download ] [ Hide ]
! ===============================================================================================
! ΠΡΟΣΟΜΟΙΩΣΗ 2007 - ΘΕΜΑ 1Δ
!================================================================================================
!  Δίνεται το παρακάτω τμήμα αλγορίθμου.
!
!    ΔΙΑΒΑΣΕ α
!    Αν α = 0 ΤΟΤΕ
!      ΕΜΦΑΝΙΣΕ "Μηδέν"
!    ΑΛΛΙΩΣ_ΑΝ α = 1 ΤΟΤΕ
!      ΕΜΦΑΝΙΣΕ "Ένα"
!    ΑΛΛΙΩΣ_ΑΝ  α = 2  ή  α = 3  ή  α = 3  ή  α = 5  ή  α = 7  ΤΟΤΕ
!      ΕΜΦΑΝΙΣΕ "Πρώτος αριθμός"
!    ΑΛΛΙΩΣ_ΑΝ α = 4  ή  α = 6  ή  α = 8  ή  α = 9   ΤΟΤΕ
!      ΕΜΦΑΝΙΣΕ "Σύνθετος αριθμός"
!    ΑΛΛΙΩΣ
!      ΕΜΦΑΝΙΣΕ "Δεν είναι μονοψήφιος θετικός"
!    ΤΕΛΟΣ_ΑΝ
!
!  Να μετατραπεί σε ισοδύναμο με αποκλειστική χρήση του σχήματος πολλαπλής επιλογής
!  ΕΠΙΛΕΞΕ .... ΤΕΛΟΣ_ΕΠΙΛΟΓΩΝ.
!================================================================================================

ΠΡΟΓΡΑΜΜΑ  PR_07_1D
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: α
ΑΡΧΗ
  ΔΙΑΒΑΣΕ α
  ΕΠΙΛΕΞΕ α
    ΠΕΡΙΠΤΩΣΗ 0
      ΓΡΑΨΕ 'Μηδέν'
    ΠΕΡΙΠΤΩΣΗ 1
      ΓΡΑΨΕ 'Ένα'
    ΠΕΡΙΠΤΩΣΗ 2 , 3 , 5 , 7
      ΓΡΑΨΕ 'Πρώτος αριθμός'
    ΠΕΡΙΠΤΩΣΗ 4 , 6 , 8 , 9
      ΓΡΑΨΕ 'Σύνθετος αριθμός'
    ΠΕΡΙΠΤΩΣΗ ΑΛΛΙΩΣ
      ΓΡΑΨΕ 'Δεν είναι μονοψήφιος θετικός'
  ΤΕΛΟΣ_ΕΠΙΛΟΓΩΝ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Σελίδα 1 από 1 Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]
Powered by phpBB® Forum Software © phpBB Group
http://www.phpbb.com/