Τώρα είναι Τετ 30 Σεπ 2020 08:49 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Εύρεση μεσαίου αριθμού
ΔημοσίευσηΔημοσιεύτηκε: Δευτ 03 Νοέμ 2003 11:45 pm 
Χωρίς σύνδεση
Διαχειριστής

Εγγραφή: Παρ 28 Φεβ 2003 06:10 pm
Δημοσιεύσεις: 84
Μία κάπως "ανορθόδοξη" υλοποίηση για να σκανδαλίσετε το ενδιαφέρον των μαθητών σας...

Syntax: [ Download ] [ Hide ]
! ==================================================
! Να γίνει πρόγραμμα που να ζητάει 3 ακέραιους
! αριθμούς και να εμφανίζει το μεσαίο από αυτούς.
! ==================================================


ΠΡΟΓΡΑΜΜΑ Εύρεση_μεσαίου_αριθμού

ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: α, β, γ, max, min

ΑΡΧΗ

  ΓΡΑΨΕ 'Δώσε 3 ακέραιους αριθμούς:'
  ΔΙΑΒΑΣΕ α,β,γ

! ---------- Τεχνική εύρεσης μεγίστου:

  max <-- α

  ΑΝ β>max ΤΟΤΕ
    max <-- β
  ΤΕΛΟΣ_ΑΝ

  ΑΝ γ>max ΤΟΤΕ
    max <-- γ
  ΤΕΛΟΣ_ΑΝ

! ---------- Τεχνική εύρεσης ελαχίστου:

  min <-- α

  ΑΝ β<min ΤΟΤΕ
    min <-- β
  ΤΕΛΟΣ_ΑΝ

  ΑΝ γ<min ΤΟΤΕ
    min <-- γ
  ΤΕΛΟΣ_ΑΝ

! ---------- Εμφάνιση του μεσαίου:

  ΓΡΑΨΕ 'Ο μεσαίος αριθμός είναι ο: ', α+β+γ-max-min

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ Εύρεση_μεσαίου_αριθμού

 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
Προβολές σελίδων: website counters