Τώρα είναι Τρί 15 Οκτ 2019 09:25 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Κυρ 09 Οκτ 2011 01:56 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 09 Οκτ 2011 01:31 pm
Δημοσιεύσεις: 1
2ο Γ.Ε.Λ. ΚΑΣΤΟΡΙΑΣ
Γιάννης Γατόπουλος

------------------------------------------------------------------------------------------------------------------
! Οι ΜΙΓΑΔΙΚΕΣ ΡΙΖΕΣ υπολογίζονται οταν Δ<0
! :arrow: UPDATE: ΒΑΣΙΚΕΣ ΑΛΛΑΓΕΣ...
! :? "Τα ΠΕΡΙΤΤΑ ΚΕΝΑ & ΑΛΛΑ ΣΤΟΙΧΕΙΑ εχουν γινει για καλυτερη εμφανιση κατα την εκτελεση..."
! :idea: Καντε COPY --> PASTE στη γλωσσομάθεια για να το εκτελέσετε.
------------------------------------------------------------------------------------------------------------------
Syntax: [ Download ] [ Hide ]
!============================================================================================
!ΑΣΚΗΣΗ:
!Δίνεται η εξίσωση αχ² + βχ + γ. Να γραφτεί πρόγραμμα που:
! i)   να διαβάζει τους συντελεστές α, β και γ της εξίσωσης.
! ii)  να βρίσκει και να εμφανίζει την τιμή και τον μέγιστο συντελεστή
!      π.χ. "Ο μέγιστος συντελεστής είναι ο Α = 3".
! iii) να βρίσκει και να εμφανίζει τις λύσεις της εξίσωσης στο συνολο των παργματικών αριθμών
!      και των μιγαδικών (αν η διακρίνουσα είναι αρνιτική).Σε οποιαδήποτε άλλη περίπτοση να
!      εμφανίζει κατάλληλο μηνυμα.
!============================================================================================

ΠΡΟΓΡΑΜΜΑ ΥΠΟΛΟΓΙΣΜΟΥ_ΕΞΙΣΩΣΗΣ
ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ: Α, Β, Γ, Δ, Ω, Ψ, ΜΑΧ
  ΧΑΡΑΚΤΗΡΕΣ: Χ
ΑΡΧΗ
  ΓΡΑΨΕ '|Δώστε τον συντελεστή α:'
  ΔΙΑΒΑΣΕ Α
  ΓΡΑΨΕ '|Δώστε τον συντελεστή β:'
  ΔΙΑΒΑΣΕ Β
  ΓΡΑΨΕ '|Δώστε τον συντελεστή γ:'
  ΔΙΑΒΑΣΕ Γ
  ΜΑΧ <-- Α
  Χ <-- 'Α'
  ΑΝ Β>ΜΑΧ ΤΟΤΕ
    ΜΑΧ <-- Β
    Χ <-- 'Β'
  ΤΕΛΟΣ_ΑΝ
  ΑΝ Γ>ΜΑΧ ΤΟΤΕ
    ΜΑΧ <-- Γ
    Χ <-- 'Γ'
  ΤΕΛΟΣ_ΑΝ
  ΓΡΑΨΕ 'Ο μέγιστος συντελεστής ειναι ο',Χ,'=',ΜΑΧ
  ΑΝ Α<>0 ΤΟΤΕ
    Δ <-- (-Β)^2 - 4*Α*Γ
    ΓΡΑΨΕ ''
    ΓΡΑΨΕ ' Η διακρίνουσα είναι:'
    ΓΡΑΨΕ ' ΑΡΑ:'
    ΑΝ Δ>0 ΤΟΤΕ
      Ω <-- (-β + Τ_Ρ(Δ))/(Α*2)
      Ψ <-- (-β - Τ_Ρ(Δ))/(Α*2)
      ΓΡΑΨΕ ' Το τριόνιμο έχει δύο διαφορετικές και άνισες ρίζες (λύσεις):'
      ΓΡΑΨΕ ''
      ΓΡΑΨΕ '   ','Χ1 =',Ω,'και','Χ2 ='
    ΑΛΛΙΩΣ_ΑΝ Δ=0 ΤΟΤΕ
      Ω <-- -Β/(Α*2)
      ΓΡΑΨΕ ' Το τριόνιμο έχει μία διπλή ρίζα:'
      ΓΡΑΨΕ ' Χ ='
    ΑΛΛΙΩΣ
      ΓΡΑΨΕ ' Το τριόνιμο είναι αδύνατο στους πραγματικούς αριθμούς R.'
      ΓΡΑΨΕ ' Οπότε έχει δύο συζιγείς μιγαδικές ρίζες:'
      Ω <-- -β/Α*2
      Ψ <-- Τ_Ρ(-Δ)/Α*2
      ΓΡΑΨΕ ''
      ΓΡΑΨΕ_ '   ','z','=',Ω,'+',Ψ,'i','   και   ','z','=',Ω,'-',Ψ,'i'
    ΤΕΛΟΣ_ΑΝ
  ΑΛΛΙΩΣ
    ΓΡΑΨΕ ''
    ΑΝ Β<>0 ΤΟΤΕ
      Ω <-- -Γ/Β
      ΓΡΑΨΕ ' Η εξίσωση έχει μία ρίζα:'
    ΑΛΛΙΩΣ
      ΓΡΑΨΕ ' Η εξίσωση ειναι αόριστη.'
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ ΥΠΟΛΟΓΙΣΜΟΥ_ΕΞΙΣΩΣΗΣ


Τελευταία επεξεργασία από JohnGatop και Παρ 11 Νοέμ 2011 10:31 pm, έχει επεξεργασθεί 11 φορά/ες συνολικά

Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters