Τώρα είναι Τετ 30 Σεπ 2020 09:21 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: ΗΛΙΚΙΑ
ΔημοσίευσηΔημοσιεύτηκε: Τρί 08 Σεπ 2009 11:31 pm 
Χωρίς σύνδεση

Εγγραφή: Τρί 08 Σεπ 2009 11:21 pm
Δημοσιεύσεις: 1
Syntax: [ Download ] [ Hide ]
!ΠΡΟΓΡΑΜΜΑ ΓΙΑ ΤΟΝ ΥΠΟΛΟΓΙΣΜΟ ΤΗΣ ΗΛΙΚΙΑΣ ΜΕ ΔΥΝΑΤΟΤΗΤΑ ΥΠΟΛΟΓΙΣΜΟΥ
!ΛΑΜΒΑΝΟΝΤΑΣ ΥΠ'ΟΨΙΝ ΤΙΣ ΠΡΟΣΘΕΤΕΣ ΗΜΕΡΕΣ ΛΟΓΩ ΔΙΣΕΚΤΩΝ ΕΤΩΝ




ΠΡΟΓΡΑΜΜΑ ΗΛΙΚΙΑ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ:  ΕΤΟΣ1, ΜΗΝΑΣ1, ΗΜΕΡΑ1, ΕΤΟΣ2, ΜΗΝΑΣ2, ΗΜΕΡΑ2 , ΧΡΟΝΙΑ, ΜΗΝΕΣ, ΗΜΕΡΕΣ, Χ, Ω
ΑΡΧΗ
  ΓΡΑΨΕ 'ΔΩΣΕ ΤΡΕΧΟΝ ΕΤΟΣ, ΜΗΝΑ ΚΑΙ ΗΜΕΡΑ'
  ΔΙΑΒΑΣΕ  ΕΤΟΣ1, ΜΗΝΑΣ1, ΗΜΕΡΑ1
  ΓΡΑΨΕ 'ΔΩΣΕ ΕΤΟΣ, ΜΗΝΑ ΚΑΙ ΗΜΕΡΑ ΓΕΝΝΗΣΗΣ'
  ΔΙΑΒΑΣΕ ΕΤΟΣ2, ΜΗΝΑΣ2, ΗΜΕΡΑ2
  ΓΡΑΨΕ 'ΓΙΑ ΑΚΡΙΒΗ ΥΠΟΛΟΓΙΣΜΟ ΠΟΥ ΣΥΜΠΕΡΙΛΑΜΒΑΝΕΙ ΤΙΣ ΠΡΟΣΘΕΤΕΣ ΗΜΕΡΕΣ ΛΟΓΩ ΔΙΣΕΚΤΩΝ ΕΤΩΝ ΠΛΗΚΤΡΟΛΟΓΗΣΕ 1'
  ΓΡΑΨΕ 'ΓΙΑ ΑΠΛΟ ΥΠΟΛΟΓΙΣΜΟ ΠΛΗΚΤΡΟΛΟΓΗΣΕ 2'
  γραψε' ΚΑΙ ΓΙΑ ΤΑ ΔΥΟ ΠΛΗΚΤΡΟΛΟΓΗΣΕ 3'
  ΔΙΑΒΑΣΕ Ω


  ΑΝ ΗΜΕΡΑ2>ΗΜΕΡΑ1 ΤΟΤΕ
    ΗΜΕΡΕΣ <-- 30-(ΗΜΕΡΑ2-ΗΜΕΡΑ1)
    ΑΝ ΜΗΝΑΣ2>=ΜΗΝΑΣ1  ΤΟΤΕ
      ΜΗΝΕΣ <-- 12- (ΜΗΝΑΣ2-ΜΗΝΑΣ1-1)
      ΧΡΟΝΙΑ <-- ΕΤΟΣ1-ΕΤΟΣ2-1
    ΑΛΛΙΩΣ
      ΜΗΝΕΣ <-- ΜΗΝΑΣ1-ΜΗΝΑΣ2-1
      ΧΡΟΝΙΑ <-- ΕΤΟΣ1-ΕΤΟΣ2
    ΤΕΛΟΣ_ΑΝ
  ΑΛΛΙΩΣ
    ΗΜΕΡΕΣ <-- ΗΜΕΡΑ1-ΗΜΕΡΑ2
    ΑΝ ΜΗΝΑΣ2>ΜΗΝΑΣ1 ΤΟΤΕ
      ΜΗΝΕΣ <-- 12- (ΜΗΝΑΣ2-ΜΗΝΑΣ1)
      ΧΡΟΝΙΑ <-- ΕΤΟΣ1-ΕΤΟΣ2-1
    ΑΛΛΙΩΣ
      ΜΗΝΕΣ <-- ΜΗΝΑΣ1- ΜΗΝΑΣ2
      ΧΡΟΝΙΑ <-- ΕΤΟΣ1-ΕΤΟΣ2
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΑΝ
  ΑΝ Ω=2 Η Ω=3 ΤΟΤΕ
    ΓΡΑΨΕ ' ΕΙΣΑΙ',  ΧΡΟΝΙΑ,  'ΧΡΟΝΩΝ',  ΜΗΝΕΣ,  'ΜΗΝΩΝ ΚΑΙ',  ΗΜΕΡΕΣ,  'ΗΜΕΡΩΝ'
  ΤΕΛΟΣ_ΑΝ
  ΑΝ Ω=1 Η Ω=3 ΤΟΤΕ
  ! δισεκτα ετη
    ΑΝ  ΕΤΟΣ1 MOD 4=0 και ΕΤΟΣ1 MOD 100<>0 Η ΕΤΟΣ1 MOD 400=0 ΤΟΤΕ
      ΑΝ  ΜΗΝΑΣ1>2 ΤΟΤΕ
        Χ <-- (ΕΤΟΣ1-ΕΤΟΣ2) DIV 4
      ΑΛΛΙΩΣ
        Χ <-- (ΕΤΟΣ1-ΕΤΟΣ2) DIV 4 -1
      ΤΕΛΟΣ_ΑΝ
    ΑΛΛΙΩΣ_ΑΝ (ΕΤΟΣ1-1) MOD 4=0 ΚΑΙ  (ΕΤΟΣ1-1)MOD 100 <>0 Η (ΕΤΟΣ1-1) MOD 400= 0 ΤΟΤΕ
      Χ <-- (ΕΤΟΣ1-1-ΕΤΟΣ2) DIV 4
    ΑΛΛΙΩΣ_ΑΝ (ΕΤΟΣ1-2) MOD 4=0 ΚΑΙ(ΕΤΟΣ1-2)MOD 100 <>0 Η (ΕΤΟΣ1-2) MOD 400=0 ΤΟΤΕ
      Χ <-- (ΕΤΟΣ1-2-ΕΤΟΣ2) DIV 4
    ΑΛΛΙΩΣ_ΑΝ (ΕΤΟΣ1-3)MOD 4=0 ΚΑΙ (ΕΤΟΣ1-3)MOD 100<>0 Η (ΕΤΟΣ1-3) MOD 400=0 ΤΟΤΕ
      Χ <-- (ΕΤΟΣ1-3-ΕΤΟΣ2) DIV 4
    ΤΕΛΟΣ_ΑΝ

    ΗΜΕΡΕΣ <-- ΗΜΕΡΕΣ +Χ
    ΑΝ ΗΜΕΡΕΣ>30 ΤΟΤΕ
      ΜΗΝΕΣ <-- ΜΗΝΕΣ+1
      ΗΜΕΡΕΣ <-- ΗΜΕΡΕΣ-30
    ΤΕΛΟΣ_ΑΝ
    ΑΝ ΜΗΝΕΣ>12 ΤΟΤΕ
      ΧΡΟΝΙΑ <-- ΧΡΟΝΙΑ+1
      ΜΗΝΕΣ <-- ΜΗΝΕΣ-12
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΑΝ


  ΓΡΑΨΕ ' ΕΙΣΑΙ',  ΧΡΟΝΙΑ,  'ΧΡΟΝΩΝ',  ΜΗΝΕΣ,  'ΜΗΝΩΝ ΚΑΙ',  ΗΜΕΡΕΣ,  'ΗΜΕΡΩΝ'
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters