Τώρα είναι Πέμ 29 Οκτ 2020 12:57 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 4 Δημοσιεύσεις ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Πέμ 02 Ιούλ 2009 12:27 pm 
Χωρίς σύνδεση

Εγγραφή: Παρ 06 Μαρ 2009 10:03 pm
Δημοσιεύσεις: 13
Τοποθεσία: Σέρρες
Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ ΜΑΘΗΜΑΤΙΚΟ_ΕΡΓΑΛΕΙΟ
ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ : Α , Χ , Υ , Ω , Π , Ο, Φ, Γ, Ξ, Κ, Λ, Τ, ς
ΑΡΧΗ
  Π <-- 1
  ΟΣΟ Π = 1 ΕΠΑΝΑΛΑΒΕ
    ΓΡΑΨΕ ' '
    ΓΡΑΨΕ ' ΠΑΤΗΣΤΕ 1 ΓΙΑ ΠΡΟΣΘΕΣΗ '
    ΓΡΑΨΕ ' ΠΑΤΗΣΤΕ 2 ΓΙΑ ΑΦΕΡΕΣΗ '
    ΓΡΑΨΕ ' ΠΑΤΗΣΤΕ 3 ΓΙΑ ΠΟΛΛΑΠΛΑΣΙΑΣΜΟ '
    ΓΡΑΨΕ ' ΠΑΤΗΣΤΕ 4 ΓΙΑ ΔΙΕΡΕΣΗ '
    ΓΡΑΨΕ ' ΠΑΤΗΣΤΕ 5 ΓΙΑ ΑΡΙΘΜΟ ΣΤΟ ΤΕΤΡΑΓΩΝΟ '
    ΓΡΑΨΕ ' ΠΑΤΗΣΤΕ 6 ΓΙΑ ΑΡΙΘΜΟ ΣΤΗΝ ΤΡΙΤΗ '
    ΓΡΑΨΕ ' ΠΑΤΗΣΤΕ 7 ΓΙΑ ΑΡΙΘΜΟ ΣΤΗΝ ΡΙΖΑ '
    ΓΡΑΨΕ ' ΠΑΤΗΣΤΕ 8 ΓΙΑ 1/x '
    ΓΡΑΨΕ ' ΠΑΤΗΣΤΕ 9 ΓΙΑ ΤΡΙΓΩΝΟΜΕΤΡΙΚΟΥΣ ΑΡΙΘΜΟΥΣ '
    ΓΡΑΨΕ ' ΠΑΤΗΣΤΕ 10 ΓΙΑ ΕΞΙΣΩΣΕΙΣ '
    ΔΙΑΒΑΣΕ Α
    ΑΝ Α = 1 ΤΟΤΕ
      ΓΡΑΨΕ ' ΔΩΣΤΕ ΤΟΥΣ ΔΥΟ ΑΡΙΘΜΟΥΣ ΠΟΥ ΘΕΛΕΤΕ ΝΑ ΠΡΟΣΘΕΣΕΤΕ '
      ΔΙΑΒΑΣΕ Χ , Υ
      Ω <-- Χ + Υ
      ΓΡΑΨΕ ' ΤΟ ΑΘΡΟΙΣΜΑ ΤΩΝ ΔΥΟ ΑΡΙΘΜΩΝ ΕΙΝΑΙ ', Ω
    ΤΕΛΟΣ_ΑΝ
    ΑΝ Α = 2 ΤΟΤΕ
      ΓΡΑΨΕ ' ΔΩΣΤΕ ΤΟΥΣ ΔΥΟ ΑΡΙΘΜΟΥΣ ΠΟΥ ΘΕΛΕΤΕ ΝΑ ΑΦΕΡΕΣΕΤΕ ΜΕ ΣΩΣΤΗ ΣΕΙΡΑ '
      ΔΙΑΒΑΣΕ Χ , Υ
      Ω <-- Χ - Υ
      ΓΡΑΨΕ ' Η ΔΙΑΦΟΡΑ ΤΩΝ ΔΥΟ ΑΡΙΘΜΩΝ ΕΙΝΑΙ ', Ω
    ΤΕΛΟΣ_ΑΝ
    ΑΝ Α = 3 ΤΟΤΕ
      ΓΡΑΨΕ ' ΔΩΣΤΕ ΤΟΥΣ ΔΥΟ ΑΡΙΘΜΟΥΣ ΠΟΥ ΘΕΛΕΤΕ ΝΑ ΠΟΛΛΑΠΛΑΣΙΑΣΕΤΕ '
      ΔΙΑΒΑΣΕ Χ , Υ
      Ω <-- Χ * Υ
      ΓΡΑΨΕ ' ΤΟ ΓΙΝΟΜΕΝΟ ΤΩΝ ΔΥΟ ΑΡΙΘΜΩΝ ΕΙΝΑΙ ', Ω
    ΤΕΛΟΣ_ΑΝ
    ΑΝ Α = 4 ΤΟΤΕ
      ΓΡΑΨΕ ' ΔΩΣΤΕ ΤΟΥΣ ΔΥΟ ΑΡΙΘΜΟΥΣ ΠΟΥ ΘΕΛΕΤΕ ΝΑ ΔΙΕΡΕΣΕΤΕ ΜΕ ΣΩΣΤΗ ΣΕΙΡΑ '
      ΔΙΑΒΑΣΕ Χ , Υ
      Ω <-- Χ / Υ
      ΓΡΑΨΕ ' ΤΟ ΠΟΙΛΙΚΟ ΤΩΝ ΔΥΟ ΑΡΙΘΜΩΝ ΕΙΝΑΙ ', Ω
    ΤΕΛΟΣ_ΑΝ
    ΑΝ Α = 5 ΤΟΤΕ
      ΓΡΑΨΕ ' ΔΩΣΤΕ ΤΟΝ ΑΡΙΘΜΟ ΠΟΥ ΘΕΛΕΤΕ ΣΤΟ ΤΕΤΡΑΓΩΝΟ '
      ΔΙΑΒΑΣΕ Χ
      Ω <-- Χ * Χ
      ΓΡΑΨΕ ' Ο ΑΡΙΘΜΟΣ ΣΤΟ ΤΕΤΡΑΓΩΝΟ ΕΙΝΑΙ ', Ω
    ΤΕΛΟΣ_ΑΝ
    ΑΝ Α = 6 ΤΟΤΕ
      ΓΡΑΨΕ ' ΔΩΣΤΕ ΤΟΝ ΑΡΙΘΜΟ ΠΟΥ ΘΕΛΕΤΕ ΣΤΗΝ ΤΡΙΤΗ '
      ΔΙΑΒΑΣΕ Χ
      Ω <-- Χ * Χ * Χ
      ΓΡΑΨΕ ' Ο ΑΡΙΘΜΟΣ ΣΤΗΝ ΤΡΙΤΗ ΕΙΝΑΙ ', Ω
    ΤΕΛΟΣ_ΑΝ
    ΑΝ Α = 7 ΤΟΤΕ
      ΓΡΑΨΕ ' ΔΩΣΤΕ ΤΟΝ ΑΡΙΘΜΟ ΠΟΥ ΘΕΛΕΤΕ ΣΤΗΝ ΡΙΖΑ '
      ΔΙΑΒΑΣΕ Χ
      Ω <-- Τ_Ρ ( Χ )
      ΓΡΑΨΕ ' Ο ΑΡΙΘΜΟΣ ΣΤΗΝ ΡΙΖΑ ΕΙΝΑΙ ', Ω
    ΤΕΛΟΣ_ΑΝ
    ΑΝ Α = 8 ΤΟΤΕ
      ΓΡΑΨΕ ' ΔΩΣΤΕ ΤΟΝ ΑΡΙΘΜΟ ΠΟΥ ΘΕΛΕΤΕ 1/x '
      ΔΙΑΒΑΣΕ Χ
      Ω <-- 1 / Χ
      ΓΡΑΨΕ ' Ο ΑΡΙΘΜΟΣ ΣΤΟ 1/x ΕΙΝΑΙ ', Ω
    ΤΕΛΟΣ_ΑΝ
    ΑΝ Α = 9 ΤΟΤΕ
      ΓΡΑΨΕ ' ΓΙΑ ΗΜΙΤΟΝΟ ΜΙΑΣ ΓΩΝΙΑΣ ΠΑΤΗΣΤΕ 1 '
      ΓΡΑΨΕ ' ΓΙΑ ΣΥΝΙΜΗΤΟΝΟ ΜΙΑΣ ΓΩΝΙΑΣ ΠΑΤΗΣΤΕ 2 '
      ΓΡΑΨΕ ' ΓΙΑ ΕΦΑΠΤΟΜΕΝΗ ΜΙΑΣ ΓΩΝΙΑΣ ΠΑΤΗΣΤΕ 3 '
      ΓΡΑΨΕ ' ΓΙΑ ΣΥΝΕΦΑΠΤΟΜΈΝΗ ΜΙΑΣ ΓΩΝΙΑΣ ΠΑΤΗΣΤΕ 4 '
      ΔΙΑΒΑΣΕ Ο
      ΑΝ Ο = 1 ΤΟΤΕ
        ΓΡΑΨΕ ' ΔΩΣΤΕ ΤΗΝ ΓΩΝΙΑ ΣΕ ΜΟΙΡΕΣ ( 0, 30, 45, 60, 90 ) '
        ΔΙΑΒΑΣΕ Π
        ΑΝ Π = 0 ΤΟΤΕ
          ΓΡΑΨΕ ' 0 '
        ΑΛΛΙΩΣ_ΑΝ Π = 30 ΤΟΤΕ
          ΓΡΑΨΕ ' 1/2 '
        ΑΛΛΙΩΣ_ΑΝ Π = 45 ΤΟΤΕ
          ΓΡΑΨΕ ' Τ_Ρ2 / 2 '
        ΑΛΛΙΩΣ_ΑΝ Π = 60 ΤΟΤΕ
          ΓΡΑΨΕ ' Τ_Ρ3 / 2 '
        ΑΛΛΙΩΣ_ΑΝ Π = 90 ΤΟΤΕ
          ΓΡΑΨΕ ' 1 '
        ΤΕΛΟΣ_ΑΝ
      ΑΛΛΙΩΣ_ΑΝ Ο = 2 ΤΟΤΕ
        ΓΡΑΨΕ ' ΔΩΣΤΕ ΤΗΝ ΓΩΝΙΑ ΣΕ ΜΟΙΡΕΣ ( 0, 30, 45, 60, 90 ) '
        ΔΙΑΒΑΣΕ Π
        ΑΝ Π = 0 ΤΟΤΕ
          ΓΡΑΨΕ ' 1 '
        ΑΛΛΙΩΣ_ΑΝ Π = 30 ΤΟΤΕ
          ΓΡΑΨΕ ' Τ_Ρ3 / 2 '
        ΑΛΛΙΩΣ_ΑΝ Π = 45 ΤΟΤΕ
          ΓΡΑΨΕ ' Τ_Ρ2 / 2 '
        ΑΛΛΙΩΣ_ΑΝ Π = 60 ΤΟΤΕ
          ΓΡΑΨΕ ' 1 / 2 '
        ΑΛΛΙΩΣ_ΑΝ Π = 90 ΤΟΤΕ
          ΓΡΑΨΕ ' 0 '
        ΤΕΛΟΣ_ΑΝ
      ΑΛΛΙΩΣ_ΑΝ Ο = 3 ΤΟΤΕ
        ΓΡΑΨΕ ' ΔΩΣΤΕ ΤΗΝ ΓΩΝΙΑ ΣΕ ΜΟΙΡΕΣ ( 0, 30, 45, 60, 90 ) '
        ΔΙΑΒΑΣΕ Π
        ΑΝ Π = 0 ΤΟΤΕ
          ΓΡΑΨΕ ' 0 '
        ΑΛΛΙΩΣ_ΑΝ Π = 30 ΤΟΤΕ
          ΓΡΑΨΕ ' Τ_Ρ3 / 3 '
        ΑΛΛΙΩΣ_ΑΝ Π = 45 ΤΟΤΕ
          ΓΡΑΨΕ ' 1 '
        ΑΛΛΙΩΣ_ΑΝ Π = 60 ΤΟΤΕ
          ΓΡΑΨΕ ' Τ_Ρ 3 '
        ΑΛΛΙΩΣ_ΑΝ Π = 90 ΤΟΤΕ
          ΓΡΑΨΕ ' ΔΕΝ ΟΡΙΖΕΤΑΙ '
        ΤΕΛΟΣ_ΑΝ
      ΑΛΛΙΩΣ_ΑΝ Ο = 4 ΤΟΤΕ
        ΓΡΑΨΕ ' ΔΩΣΤΕ ΤΗΝ ΓΩΝΙΑ ΣΕ ΜΟΙΡΕΣ ( 0, 30, 45, 60, 90 ) '
        ΔΙΑΒΑΣΕ Π
        ΑΝ Π = 0 ΤΟΤΕ
          ΓΡΑΨΕ ' ΔΕΝ ΟΡΙΖΕΤΑΙ '
        ΑΛΛΙΩΣ_ΑΝ Π = 30 ΤΟΤΕ
          ΓΡΑΨΕ ' Τ_Ρ3 '
        ΑΛΛΙΩΣ_ΑΝ Π = 45 ΤΟΤΕ
          ΓΡΑΨΕ ' 1 '
        ΑΛΛΙΩΣ_ΑΝ Π = 60 ΤΟΤΕ
          ΓΡΑΨΕ ' Τ_Ρ3 / 3 '
        ΑΛΛΙΩΣ_ΑΝ Π = 90 ΤΟΤΕ
          ΓΡΑΨΕ ' 0 '
        ΤΕΛΟΣ_ΑΝ
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΑΝ
    ΑΝ Α = 10 ΤΟΤΕ                                                                                                
      ΓΡΑΨΕ ' ΠΑΤΗΣΤΕ 1 ΓΙΑ ΕΞΙΣΩΣΕΙΣ 1ου ΒΑΘΜΟΥ '
      ΓΡΑΨΕ ' ΠΑΤΗΣΤΕ 2 ΓΙΑ ΕΞΙΣΩΣΕΙΣ 2ου ΒΑΘΜΟΥ '
      ΔΙΑΒΑΣΕ ς
      ΑΝ ς = 1 ΤΟΤΕ
        ΓΡΑΨΕ ' ΔΩΣΤΕ ΤΟΝ ΜΕΤΑΒΛΗΤΗ ΤΟΥ χ '
        ΓΡΑΨΕ ' ΚΑΙ ΜΕΤΑ ΤΟΝ ΣΤΑΘΕΡΟ ΟΡΟ '
        ΔΙΑΒΑΣΕ Γ, Φ
        Ξ <-- - Φ / Γ
        ΓΡΑΨΕ ' ΤΟ χ ΕΙΝΑΙ ', Ξ
      ΑΛΛΙΩΣ_ΑΝ ς = 2 ΤΟΤΕ
        ΓΡΑΨΕ ' ΔΩΣΤΕ ΤΟΝ ΜΕΤΑΒΛΗΤΗ ΤΟΥ χ^2, '
        ΓΡΑΨΕ ' ΜΕΤΑ ΔΩΣΤΕ ΤΟΝ ΜΕΤΑΒΛΗΤΗ ΤΟΥ χ '
        ΓΡΑΨΕ ' ΚΑΙ ΤΕΛΟΣ ΔΩΣΤΕ ΤΟΝ ΣΤΑΘΕΡΟ ΟΡΟ '
        ΔΙΑΒΑΣΕ Γ, Φ, Τ
        Κ <-- ( - Φ + ( Τ_Ρ ( ( Φ * Φ ) - ( 4 * Γ * Τ ) ) ) ) / ( 2 * Γ )
        Λ <-- ( - Φ - ( Τ_Ρ ( ( Φ * Φ ) - ( 4 * Γ * Τ ) ) ) ) / ( 2 * Γ )
        ΓΡΑΨΕ ' ΤΟ χ ΕΙΝΑΙ ', Κ
        ΓΡΑΨΕ ' Ή ΤΟ χ ΕΙΝΑΙ ', Λ
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΑΝ
    ΓΡΑΨΕ ' ΠΑΤΗΣΤΕ 1 ΓΙΑ ΤΕΡΜΑΤΙΣΜΟ Ή 2 ΓΙΑ ΣΥΝΕΧΕΙΑ '
    ΔΙΑΒΑΣΕ Ο
    ΑΝ Ο = 2 ΤΟΤΕ
      Π <-- 1
    ΤΕΛΟΣ_ΑΝ
    ΑΝ Ο = 1 ΤΟΤΕ
      Π <-- 2
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ ' BY : L. D. KOSTAS ΑΠΟ Β ΛΥΚΕΙΟΥ ΡΟΔΟΛΙΒΟΥΣ '
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ ΜΑΘΗΜΑΤΙΚΟ_ΕΡΓΑΛΕΙΟ


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Παρατηρήσεις
ΔημοσίευσηΔημοσιεύτηκε: Πέμ 02 Ιούλ 2009 06:17 pm 
Χωρίς σύνδεση

Εγγραφή: Παρ 06 Μαρ 2009 10:03 pm
Δημοσιεύσεις: 13
Τοποθεσία: Σέρρες
Οποιαδήποτε παρατήρηση δεκτή !!!


Κορυφή
 Προφίλ  
 
ΔημοσίευσηΔημοσιεύτηκε: Πέμ 02 Ιούλ 2009 10:58 pm 
Χωρίς σύνδεση

Εγγραφή: Παρ 30 Μάιος 2008 09:46 pm
Δημοσιεύσεις: 49
Καλή δουλειά αλλά νομίζω ότι θα έπρεπε να ελέγχει το πρόγραμμα τη εισάγει ο χρήστης στην αρχή και στο τέλος που ρωτάει για τερματισμό ή συνέχεια/επανάληψη. Επίσης καλό θα ήταν να ελέγχει και για τις διαιρέσεις με το 0 (στην διαίρεση , στον αντίστροφο και στις εξισώσεις ). Τέλος κάποιες καλές προσθήκες θα ήταν το αντίθετο, η απόλυτη τιμή και η στρογγυλοποίηση (με ή χωρίς επιλογή ψηφίου στο οποίο θέλουμε να γίνει ).

_________________
"Δύο πράγματα είναι ατελείωτα (άπειρα), το σύμπαν και η ανθρώπινη βλακεία, για το 1ο δεν είμαι σίγουρος." Einstein
"Τα πάντα ρει" (Τα πάντα ρέουν/αλλάζουν) Ηράκλειτος
"Μη μου τους κύκλους τάραττε" Αρχιμήδης


Κορυφή
 Προφίλ  
 
ΔημοσίευσηΔημοσιεύτηκε: Παρ 03 Ιούλ 2009 01:05 pm 
Χωρίς σύνδεση

Εγγραφή: Παρ 06 Μαρ 2009 10:03 pm
Δημοσιεύσεις: 13
Τοποθεσία: Σέρρες
Όσον αφορά τον τερματισμό και την συνέχεια το έχω βάλει ήδη, αλλά δεν έχω τελειοποιήσει την διαίρεση ακόμη.


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 4 Δημοσιεύσεις ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters