Τώρα είναι Σάβ 22 Φεβ 2020 02:41 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 2 Δημοσιεύσεις ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: ΑΠΟΡΙΑ ΣΧΕΤΙΚΑ ΜΕ ΤΟ ΑΝ
ΔημοσίευσηΔημοσιεύτηκε: Τετ 04 Μαρ 2009 11:01 pm 
Χωρίς σύνδεση

Εγγραφή: Τετ 04 Μαρ 2009 10:46 pm
Δημοσιεύσεις: 5
ΘΑ ΗΘΕΛΑ ΝΑ ΣΑΣ ΡΩΤΗΣΩ ΠΩΣ ΜΠΟΡΩ ΝΑ ΠΩ ΟΤΙ ΑΝ ΔΙΝΕΤΑΙ ΑΥΤΗ Η ΛΕΞΗ ΤΟΤΕ ΓΡΑΨΕ ΑΥΤΟ;

ΕΓΩ ΕΧΩ ΓΡΑΨΕΙ

ΑΝ (ΤΙ ΒΑΖΩ ΕΔΩ;) ΤΟΤΕ
ΓΡΑΨΕ 'Η λέξη στα ελληνικά είναι η εξής:'

ΤΙ ΠΡΕΠΕΙ ΝΑ ΒΑΛΩ ΑΝΑΜΕΣΑ ΣΤΟ ΑΝ ΚΑΙ ΤΟ ΤΟΤΕ ΩΣΤΕ ΝΑ ΜΟΥ ΒΓΑΖΕΙ ΟΤΙ ΑΝΑΓΝΩΡΙΖΕΙ ΤΗΝ ΛΕΞΗ;


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Re: ΑΠΟΡΙΑ ΣΧΕΤΙΚΑ ΜΕ ΤΟ ΑΝ
ΔημοσίευσηΔημοσιεύτηκε: Σάβ 07 Μαρ 2009 12:51 pm 
Χωρίς σύνδεση

Εγγραφή: Παρ 30 Μάιος 2008 09:46 pm
Δημοσιεύσεις: 49
Υπάρχουν διάφοροι τρόποι, 2 που μπορώ να σκεφτώ είναι οι παρακάτω:
α΄) ΑΝ χ = ’ναι’ ΤΟΤΕ
Όπου χ θα βάλεις την μεταβλητή στην οποία έχεις την λέξη, και στην θέση του ναι την λέξη που όταν την βρίσκει θες να εκτελεί αυτό που έχεις μέσα στην αν
Π.χ.
Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ ΑΝ_ΛΕΞΗ
ΜΕΤΑΒΛΗΤΕΣ
  ΧΑΡΑΚΤΗΡΕΣ: Α
ΑΡΧΗ
  ΔΙΑΒΑΣΕ Α
  ΑΝ Α = 'ΕΝΤΑΞΕΙ' ΤΟΤΕ
    ΓΡΑΨΕ 'ΕΧΕΤΕ ΓΡΑΨΕΙ ΕΝΤΑΞΕΙ'
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


β΄) ΑΝ χ = υ ΤΟΤΕ
Όπου χ θα βάλεις την μεταβλητή στην οποία έχεις την λέξη όπως και στο α΄ , και στο υ θα βάλεις μια μεταβλητή στην οποία θα καταχωρείς την λέξη που όταν την βρίσκει θες να εκτελεί αυτό που έχεις μέσα στην αν
Π.χ.
Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ ΑΝ_ΛΕΞΗ
ΜΕΤΑΒΛΗΤΕΣ
  ΧΑΡΑΚΤΗΡΕΣ: Α, Β
ΑΡΧΗ
  ΔΙΑΒΑΣΕ Α
  Β <-- 'ΕΝΤΑΞΕΙ'
  ΑΝ Α = Β ΤΟΤΕ
    ΓΡΑΨΕ 'ΕΧΕΤΕ ΓΡΑΨΕΙ ΕΝΤΑΞΕΙ'
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ ΑΝ_ΛΕΞΗ
ΜΕΤΑΒΛΗΤΕΣ
  ΧΑΡΑΚΤΗΡΕΣ: Α, Β
ΑΡΧΗ
  ΔΙΑΒΑΣΕ Α
  ΔΙΑΒΑΣΕ Β
  ΑΝ Α = Β ΤΟΤΕ
    ΓΡΑΨΕ 'ΕΧΕΤΕ ΓΡΑΨΕΙ ΤΟ ΙΔΙΟ 2 ΦΟΡΕΣ'
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Σημείωση: τα 2 πρώτα παραδείγματα κάνουν ακριβώς το ίδιο

Ελπίζω να βοήθησα.

_________________
"Δύο πράγματα είναι ατελείωτα (άπειρα), το σύμπαν και η ανθρώπινη βλακεία, για το 1ο δεν είμαι σίγουρος." Einstein
"Τα πάντα ρει" (Τα πάντα ρέουν/αλλάζουν) Ηράκλειτος
"Μη μου τους κύκλους τάραττε" Αρχιμήδης


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 2 Δημοσιεύσεις ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters