Τώρα είναι Τετ 30 Σεπ 2020 09:02 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Υπολογισμός ΦΠΑ
ΔημοσίευσηΔημοσιεύτηκε: Σάβ 20 Οκτ 2007 10:15 pm 
Χωρίς σύνδεση

Εγγραφή: Σάβ 20 Οκτ 2007 03:17 pm
Δημοσιεύσεις: 3
Τοποθεσία: Θεσσαλονίκη
Syntax: [ Download ] [ Hide ]
! ----------------------------------------
! Το πρόγραμμα θα υπολογίζει το Φόρο Προστιθεμένης Αξίας (ΦΠΑ) του προϊόντος
! ----------------------------------------

ΠΡΟΓΡΑΜΜΑ Υπολογισμός_ΦΠΑ

ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ: Τιμή_προιόντος, Φόρος_Προστιθέμενης_Αξίας, ΦΠΑ_1, ΦΠΑ_2, ΦΠΑ

ΑΡΧΗ

  ΓΡΑΨΕ 'Δώσε την τιμή του προιόντος:'
  ΔΙΑΒΑΣΕ Τιμή_προιόντος

  ΓΡΑΨΕ 'Δώσε το ποσοστό του ΦΠΑ του προιόντος [9/19]'
  ΔΙΑΒΑΣΕ Φόρος_Προστιθέμενης_Αξίας

  ΑΝ Φόρος_Προστιθέμενης_Αξίας = 9 ΤΟΤΕ
    ΦΠΑ_1 <-- (Τιμή_προιόντος * 9) / 100
    ΓΡΑΨΕ 'Ο ΦΠΑ του προιόντος είναι',ΦΠΑ_1,'Ευρώ'
  ΑΛΛΙΩΣ
    ΑΝ Φόρος_Προστιθέμενης_Αξίας = 19 ΤΟΤΕ
      ΦΠΑ_2 <-- (Τιμή_προιόντος * 19) / 100
      ΓΡΑΨΕ 'Ο ΦΠΑ του προιόντος είναι',ΦΠΑ_2,'Ευρώ'
    ΑΛΛΙΩΣ
      ΓΡΑΨΕ 'Το ποσοστό του ΦΠΑ πρέπει να είναι 9 ή 19 τις εκατό'
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΑΝ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ   Υπολογισμός_ΦΠΑ
 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση: Δεν υπάρχουν εγγεγραμμένα μέλη και 2 επισκέπτες


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
Προβολές σελίδων: website counters