Τώρα είναι Σάβ 22 Φεβ 2020 03:30 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Κυρ 24 Δεκ 2006 09:35 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 12 Οκτ 2003 01:52 am
Δημοσιεύσεις: 189
Τοποθεσία: ΝΙΚΑΙΑ - ΠΕΙΡΑΙΑΣ
Syntax: [ Download ] [ Hide ]
! Ένα κατάστημα πώλησης σκαφών αναψυχής κάνει έκπτωση στην τιμή πώλησης κάθε σκάφους
! ανάλογα με το μήκος του σκάφους και τον αριθμό των δόσεων με βάση τον πίνακα που ακολουθεί.
!
!   Μήκος σκάφους σε μέτρα | Αριθμός δόσεων | Έκπτωση %
!   ---------------------------------------------------
!                          |   0 έως και 6  |   12
!                          |  7 έως και 12  |    8
!       Έως 6 μέτρα        | 13 έως και 24  |    6
!                          | 25 έως και 60  |    2
!                          |  πάνω από 60   |    0            
!   ---------------------------------------------------
!                          |   0 έως και 6  |   15
!                          |   7 έως και 12 |   10
!     Πάνω από 6 μέτρα     |  13 έως και 24 |    8
!                          |  25 έως και 60 |    4
!                          |  πάνω από 60   |    0
!   ---------------------------------------------------
! Να γράψετε πρόγραμμα το οποίο :
!  · να δέχεται την αρχική τιμή του σκάφους, το μήκος του και τον αριθμό των δόσεων και
!  · να εμφανίζει την τελική τιμή πώλησής του και το ποσό της κάθε δόσης.

ΠΡΟΓΡΑΜΜΑ ΕΠ_1_10
ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ: a,x,y,e,poso
ΑΡΧΗ
  ΓΡΑΨΕ 'Δώσε την αξία του σκάφους.'
  ΔΙΑΒΑΣΕ a
  ΓΡΑΨΕ 'Δώσε και το μήκος του.'
  ΔΙΑΒΑΣΕ x
  ΓΡΑΨΕ 'Δώσε τον αριθμό των δόσεων.'
  ΔΙΑΒΑΣΕ y
  ΑΝ x < 6 ΤΟΤΕ
    ΑΝ y < 6 ΤΟΤΕ
      e <-- 12
    ΑΛΛΙΩΣ_ΑΝ y < 12 ΤΟΤΕ
      e <-- 8
    ΑΛΛΙΩΣ_ΑΝ y < 24 ΤΟΤΕ
      e <-- 6
    ΑΛΛΙΩΣ_ΑΝ y < 60 ΤΟΤΕ
      e <-- 2
    ΑΛΛΙΩΣ
      e <-- 0
    ΤΕΛΟΣ_ΑΝ
  ΑΛΛΙΩΣ
    ΑΝ y < 6 ΤΟΤΕ
      e <-- 15
    ΑΛΛΙΩΣ_ΑΝ y < 12 ΤΟΤΕ
      e <-- 10
    ΑΛΛΙΩΣ_ΑΝ y < 24 ΤΟΤΕ
      e <-- 8
    ΑΛΛΙΩΣ_ΑΝ y < 60 ΤΟΤΕ
      e <-- 4
    ΑΛΛΙΩΣ
      e <-- 0
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΑΝ
  poso <-- a - a*e/100
  ΓΡΑΨΕ 'Τελική αξία σκάφους',poso,'EURO'
  ΓΡΑΨΕ 'Ποσό κάθε δόσης',poso/y,'EURO'
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters