Τώρα είναι Σάβ 22 Φεβ 2020 03:19 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Στρογγυλοποίηση Δεκαδικού 2
ΔημοσίευσηΔημοσιεύτηκε: Σάβ 25 Νοέμ 2006 02:22 am 
Χωρίς σύνδεση

Εγγραφή: Πέμ 22 Απρ 2004 11:16 am
Δημοσιεύσεις: 60
Τοποθεσία: Θεσσαλονίκη
Να γίνει πρόγραμμα που να διαβάζει ένα δεκαδικό αριθμό (με οσοδήποτε δεκαδικά) και να τον στρογγυλοποιεί στα δύο δεκαδικά του ψηφία. Δηλαδή, αν ο αριθμός είναι ο 74,3546 να γίνει 74,35 και αν είναι ο 4,736 να γίνει 4,74. Προσπαθήστε να το λύσετε και χωρίς χρήση της εντολής ΑΝ.


ΛΥΣΗ 1η (με δομη επιλογής)
Syntax: [ Download ] [ Hide ]

ΠΡΟΓΡΑΜΜΑ Στρογγυλοποίηση_Δεκαδικου_2
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ:Ν,Υπ
  ΠΡΑΓΜΑΤΙΚΕΣ: Α
ΑΡΧΗ
  ΓΡΑΨΕ 'Δώσε δεκαδικό αριθμό'
  ΔΙΑΒΑΣΕ Α
  Ν <-- Α_Μ(Α * 1000)
  Υπ <-- Ν MOD 10
  Α <-- (Ν-Υπ)/1000
  ΑΝ 5<Υπ ΤΟΤΕ
    Α <-- Α +0.01
  ΤΕΛΟΣ_ΑΝ
  ΓΡΑΨΕ 'Στρογγυλοποιημένος αριθμος='
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

 


ΛΥΣΗ 2η (ΜΟΝΟ με δομη ακολουθίας)
Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ Στρογγυλοποίηση_Δεκαδικου_2
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ:Ν,Υπ
  ΠΡΑΓΜΑΤΙΚΕΣ: Α
ΑΡΧΗ
  ΓΡΑΨΕ 'Δώσε δεκαδικό αριθμό'
  ΔΙΑΒΑΣΕ Α
  Α <-- Α+0.005
  Ν <-- Α_Μ(Α * 1000)
  Υπ <-- Ν MOD 10
  Α <-- (Ν-Υπ)/1000
  ΓΡΑΨΕ 'Στρογγυλοποιημένος αριθμος='
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 

_________________
Φρειδερίκος Κώστας
FreiderikosK@hotmail.com


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters