Τώρα είναι Παρ 28 Φεβ 2020 09:52 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 2 Δημοσιεύσεις ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Εύρεση μεγίστου
ΔημοσίευσηΔημοσιεύτηκε: Δευτ 10 Μαρ 2003 10:52 pm 
Χωρίς σύνδεση
Διαχειριστής

Εγγραφή: Παρ 28 Φεβ 2003 06:10 pm
Δημοσιεύσεις: 84
Syntax: [ Download ] [ Hide ]
! ============================================
! Να γίνει πρόγραμμα που να ζητάει 4 ακέραιες
! τιμές τις οποίες θα αποθηκεύει σε 4
! διαφορετικές μεταβλητές. Στη συνέχεια να
! εμφανίζει τη μεγαλύτερη από αυτές.
! ============================================


ΠΡΟΓΡΑΜΜΑ Εύρεση_μεγίστου

ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: α, β, γ, δ, max

ΑΡΧΗ

  ΓΡΑΨΕ 'Δώσε τον αριθμό α: '
  ΔΙΑΒΑΣΕ α
  ΓΡΑΨΕ 'Δώσε τον αριθμό β: '
  ΔΙΑΒΑΣΕ β
  ΓΡΑΨΕ 'Δώσε τον αριθμό γ: '
  ΔΙΑΒΑΣΕ γ
  ΓΡΑΨΕ 'Δώσε τον αριθμό δ: '
  ΔΙΑΒΑΣΕ δ

  max <-- α
  ΑΝ β>max ΤΟΤΕ
    max <-- β
  ΤΕΛΟΣ_ΑΝ
  ΑΝ γ>max ΤΟΤΕ
    max <-- γ
  ΤΕΛΟΣ_ΑΝ
  ΑΝ δ>max ΤΟΤΕ
    max <-- δ
  ΤΕΛΟΣ_ΑΝ

  ΓΡΑΨΕ 'Ο μεγαλύτερος αριθμός είναι ο: ', max

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ Εύρεση_μεγίστου

 


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Re: Εύρεση μεγίστου
ΔημοσίευσηΔημοσιεύτηκε: Πέμ 17 Απρ 2008 02:11 am 
Χωρίς σύνδεση

Εγγραφή: Πέμ 17 Απρ 2008 02:05 am
Δημοσιεύσεις: 1
Αν το έκανες με πίνακα δεν θα ήταν καλύτερα??? Θα μπορούσες να βρεις το max από όσους αριθμούς θα ήθελες και δεν θα περιοριζόσουν σε 4.


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 2 Δημοσιεύσεις ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters