Τώρα είναι Τετ 30 Σεπ 2020 09:06 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 2 Δημοσιεύσεις ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Σάβ 19 Νοέμ 2005 10:00 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 06 Νοέμ 2005 01:44 am
Δημοσιεύσεις: 2
Τοποθεσία: ΑΘΗΝΑ
Syntax: [ Download ] [ Hide ]
!Ο ΑΛΓΟΡΙΘΜΟΣ ΑΥΤΟΣ ΥΠΟΛΟΓΙΖΕΙ ΤΟ ΗΜΙΤΟΝΟ Η ΤΟ ΣΥΝΗΜΙΤΟΝΟ
!ΜΙΑΣ ΓΩΝΙΑΣ ΑΝ ΞΕΡΕΙΣ ΤΟ ΣΥΝΗΜΙΤΟΝΟ Η ΤΟ ΗΜΙΤΟΝΟ ΑΝΤΙΣΤΟΙΧΑ
ΠΡΟΓΡΑΜΜΑ ΥΠΟΛΟΓΙΣΜΟΣ_ΗΜΙΤΟΝΟΥ_Η_ΣΥΝΗΜΙΤΟΝΟΥ
ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ: ΣΥΝΗΜΙΤΟΝΟ,ΗΜΙΤΟΝΟ,ΓΝΩΣΗ
ΑΡΧΗ
  ΓΡΑΨΕ 'ΓΝΩΡΙΖΕΙΣ ΤΟ ΗΜΙΤΟΝΟ Η ΤΟ ΣΥΝΗΜΙΤΟΝΟ?ΑΝ ΓΝΩΡΙΖΕΙΣ ΤΟ ΗΜΙΤΟΝΟ ΠΛΗΚΤΡΟΛΟΓΗΣΕ 1 ΑΛΛΙΩΣ ΑΝ ΓΝΩΡΙΖΕΙΣ ΤΟ ΣΥΝΗΜΙΤΟΝΟ ΠΛΗΚΤΡΟΛΟΓΗΣΕ 2'
  ΔΙΑΒΑΣΕ ΓΝΩΣΗ
  ΑΝ ΓΝΩΣΗ=1 ΤΟΤΕ
    ΓΡΑΨΕ 'ΔΩΣΕ ΤΟ ΗΜΙΤΟΝΟ'
    ΔΙΑΒΑΣΕ ΗΜΙΤΟΝΟ
    ΑΝ ΗΜΙΤΟΝΟ=1 ΤΟΤΕ
      ΓΡΑΨΕ'ΤΟ ΣΥΝΗΜΙΤΟΝΟ ΤΗΣ ΓΩΝΙΑΣ ΕΙΝΑΙ 0 '
    ΑΛΛΙΩΣ_ΑΝ ΗΜΙΤΟΝΟ=0 ΤΟΤΕ
      ΓΡΑΨΕ 'ΤΟ ΣΥΝΗΜΙΤΟΝΟ ΤΗΣ ΓΩΝΙΑΣ ΕΙΝΑΙ 1'
    ΑΛΛΙΩΣ
      ΣΥΝΗΜΙΤΟΝΟ <-- (1-ΗΜΙΤΟΝΟ^2)^(0.5)
      ΓΡΑΨΕ 'ΤΟ ΣΥΝΗΜΙΤΟΝΟ ΤΗΣ ΓΩΝΙΑΣ ΕΙΝΑΙ'
      ΓΡΑΨΕ ΣΥΝΗΜΙΤΟΝΟ
    ΤΕΛΟΣ_ΑΝ
  ΑΛΛΙΩΣ_ΑΝ ΓΝΩΣΗ=2 ΤΟΤΕ
    ΓΡΑΨΕ 'ΔΩΣΕ ΤΟ ΣΥΝΗΜΙΤΟΝΟ'
    ΔΙΑΒΑΣΕ ΣΥΝΗΜΙΤΟΝΟ
    ΑΝ ΣΥΝΗΜΙΤΟΝΟ=1 ΤΟΤΕ
      ΓΡΑΨΕ 'ΤΟ ΗΜΙΤΟΝΟ ΤΗΣ ΓΩΝΙΑΣ ΕΙΝΑΙ 0 '
    ΑΛΛΙΩΣ_ΑΝ ΣΥΝΗΜΙΤΟΝΟ=0 ΤΟΤΕ
      ΓΡΑΨΕ 'ΤΟ ΗΜΙΤΟΝΟ ΤΗΣ ΓΩΝΙΑΣ ΕΙΝΑΙ 1'
    ΑΛΛΙΩΣ
      ΗΜΙΤΟΝΟ <-- (1-ΣΥΝΗΜΙΤΟΝΟ^2)^(0.5)
      ΓΡΑΨΕ 'ΤΟ ΗΜΙΤΟΝΟ ΤΗΣ ΓΩΝΙΑΣ ΕΙΝΑΙ'
      ΓΡΑΨΕ ΗΜΙΤΟΝΟ
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ ΥΠΟΛΟΓΙΣΜΟΣ_ΗΜΙΤΟΝΟΥ_Η_ΣΥΝΗΜΙΤΟΝΟΥ
 


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης:
ΔημοσίευσηΔημοσιεύτηκε: Πέμ 24 Νοέμ 2005 09:39 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 30 Νοέμ 2003 07:20 pm
Δημοσιεύσεις: 5
Τοποθεσία: Αθήνα - Κηφισιά
Θα πρέπει να γίνει έλεγχος για μη αποδεκτές τιμές του ημιτόνου και συνημιτόνου

_________________
Δημήτρης Παπακωνσταντίνου


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 2 Δημοσιεύσεις ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση: Δεν υπάρχουν εγγεγραμμένα μέλη και 3 επισκέπτες


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters