Τώρα είναι Παρ 28 Φεβ 2020 08:25 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Υπολογισμός_Εισφορών
ΔημοσίευσηΔημοσιεύτηκε: Τετ 18 Φεβ 2004 05:38 am 
Χωρίς σύνδεση

Εγγραφή: Παρ 14 Μαρ 2003 06:19 pm
Δημοσιεύσεις: 13
Syntax: [ Download ] [ Hide ]
!============================================================
! Να γραφεί πρόγραμμα το οποίο να ζητά από το χρήστη το Μισθό
! ενός εργαζόμενου καθώς και την ειδικοτητά του. Κατόπιν να
! υπολογίζει το ποσό των εισφορών το οποίο θα πρέπει να
! καταβάλλει ο εργαζόμενος, καθώς και το ύψος του τελικού
! μισθού του, σύμφωνα με τα παρακάτω στοιχεία:
!       ΥΨΟΣ ΜΙΣΘΟΥ          ΕΙΣΦΟΡΑ1     ΕΙΣΦΟΡΑ2
!       μέχρι 1500 ευρώ         5%           4%
!       από 1501 - 2500         7%           6%
!       από 2501 - 4000         9%           8%
!       από 4001 -             12%          11%
! Αν ο εργαζόμενος έχει ειδικότητα 'ΤΕΧΝΙΚΟΣ' τότε ή ΕΙΣΦΟΡΑ1
! προσαυξάνεται κατά 3% και ή ΕΙΣΦΟΡΑ2 κατά 4%, ενώ αν ο
! εργαζόμενος έχει ειδικότητα ΠΩΛΗΤΗΣ τότε ή ΕΙΣΦΟΡΑ1
! προσαυξάνεται κατά 4% και ή ΕΙΣΦΟΡΑ2 κατά 5%. Τέλος το
! σύνολο των εισφορών που καλείται να πληρώσει ο εργαζόμενος
! δεν μπορεί να υπερβεί σε καμμία περίπτωση το ποσό των
! 5000 ευρώ.
!============================================================
! (panos giannakopoulos)
!============================================================

ΠΡΟΓΡΑΜΜΑ Υπολογισμός_Εισφορών
ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ: Μισθός, Τελικός_Μισθός, Εισφορά1, Εισφορά2, Σύνολο_Εισφορών
  ΧΑΡΑΚΤΗΡΕΣ: Ειδικότητα
ΑΡΧΗ
  ΓΡΑΨΕ 'Δώσε μισθό'
  ΔΙΑΒΑΣΕ Μισθός
  ΓΡΑΨΕ 'Δώσε ειδικότητα (ΤΕΧΝΙΚΟΣ/ΠΩΛΗΤΗΣ/ΑΛΛΟ)'
  ΔΙΑΒΑΣΕ Ειδικότητα

  ΑΝ Μισθός <= 15000 ΤΟΤΕ
    Εισφορά1 <-- Μισθός * 0.05
    Εισφορά2 <-- Μισθός * 0.04
  ΑΛΛΙΩΣ_ΑΝ (Μισθός > 1500) ΚΑΙ (Μισθός <= 2500) ΤΟΤΕ
    Εισφορά1 <-- Μισθός * 0.07
    Εισφορά2 <-- Μισθός * 0.06
  ΑΛΛΙΩΣ_ΑΝ (Μισθός > 2500) ΚΑΙ (Μισθός <= 4000) ΤΟΤΕ
    Εισφορά1 <-- Μισθός * 0.09
    Εισφορά2 <-- Μισθός * 0.08
  ΑΛΛΙΩΣ
    Εισφορά1 <-- Μισθός * 0.12
    Εισφορά2 <-- Μισθός * 0.11
  ΤΕΛΟΣ_ΑΝ

  ΑΝ Ειδικότητα = 'ΤΕΧΝΙΚΟΣ' ΤΟΤΕ
    Εισφορά1 <-- Εισφορά1 + (Μισθός * 0.03)
    Εισφορά2 <-- Εισφορά2 + (Μισθός * 0.04)
  ΑΛΛΙΩΣ_ΑΝ Ειδικότητα = 'ΠΩΛΗΤΗΣ' ΤΟΤΕ
    Εισφορά1 <-- Εισφορά1 + (Μισθός * 0.04)
    Εισφορά2 <-- Εισφορά2 + (Μισθός * 0.05)
  ΤΕΛΟΣ_ΑΝ

  Σύνολο_Εισφορών <-- Εισφορά1 + Εισφορά2
  Τελικός_Μισθός <-- Μισθός - Σύνολο_Εισφορών

  ΑΝ Σύνολο_Εισφορών > 5000 ΤΟΤΕ
    Σύνολο_Εισφορών <-- 5000
  ΤΕΛΟΣ_ΑΝ

  ΓΡΑΨΕ 'Με αρχικό μισθό: ', Μισθός:7:2,' και ειδικότητα: ', Ειδικότητα
  ΓΡΑΨΕ 'η πρώτη εισφορά είναι_________:', Εισφορά1
  ΓΡΑΨΕ 'η δεύτερη εισφορά είναι_______:', Εισφορά2
  ΓΡΑΨΕ 'το σύνολο των εισφορών είναι__:', Σύνολο_Εισφορών
  ΓΡΑΨΕ 'και ο Τελικός Μισθός είναι____:', Τελικός_Μισθός

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ Υπολογισμός_Εισφορών                                                            


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters