Τώρα είναι Τρί 15 Οκτ 2019 09:39 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Δευτ 30 Δεκ 2013 09:13 pm 
Χωρίς σύνδεση

Εγγραφή: Πέμ 26 Δεκ 2013 12:46 pm
Δημοσιεύσεις: 8
    Συγνωμη,επειδη ο τροπος για να βρει αν ο αριθμος ειναι πρωτος γινετε με ΑΝ, προτιμισα να το βαλω εδω παρολο που χρησιμοποιω δομη επαναληψης(μονο για εγκυροτητα και επανεκτελεση).

Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ  πρωτοι_αριθμοι
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ:αρ
  ΧΑΡΑΚΤΗΡΕΣ:απ
ΑΡΧΗ
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
      ΓΡΑΨΕ 'Δωσε εναν αριθμο μεγαλυτερο του 1'
      ΔΙΑΒΑΣΕ αρ
    ΜΕΧΡΙΣ_ΟΤΟΥ αρ>1
    ΑΝ (αρ=2 η αρ=3 η αρ=5)η(αρ MOD 2<>0 και αρ MOD 3<>0 και αρ MOD 5<>0) τότε !ΕΛΕΓΧΕΤΑΙ ΑΝ ΕΙΝΑΙ ΠΡΩΤΟΣ ΜΟΝΟ ΜΕ ΜΙΑ ΣΥΝΘΗΚΗ
      ΓΡΑΨΕ 'ο αριθμος',αρ,'ειναι πρωτος'
    ΑΛΛΙΩΣ
      ΓΡΑΨΕ 'ο αριθμος',αρ,'δεν ειναι πρωτος'
    ΤΕΛΟΣ_ΑΝ
    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
      ΓΡΑΨΕ 'ΞΑΝΑ?(ναι η οχι)'
      ΔΙΑΒΑΣΕ απ
    ΜΕΧΡΙΣ_ΟΤΟΥ απ='ναι' η απ='οχι'
  ΜΕΧΡΙΣ_ΟΤΟΥ απ='οχι'
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


 

_________________
paul


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters