Τώρα είναι Τρί 07 Ιούλ 2020 08:12 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Προσομοίωση - Θέμα 1Γ
ΔημοσίευσηΔημοσιεύτηκε: Παρ 18 Μάιος 2007 08:24 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 12 Οκτ 2003 01:52 am
Δημοσιεύσεις: 189
Τοποθεσία: ΝΙΚΑΙΑ - ΠΕΙΡΑΙΑΣ
Syntax: [ Download ] [ Hide ]
! ===============================================================
! ΠΡΟΣΟΜΟΙΩΣΗ 2006 - ΘΕΜΑ 1Γ
! ===============================================================
! Δίνεται το ακόλουθο πρόγραμμα σε 'ΓΛΩΣΣΑ'
!
!  ΠΡΟΓΡΑΜΜΑ Σύγκριση
!  ΜΕΤΑΒΛΗΤΕΣ
!    ΑΚΕΡΑΙΕΣ : x , y , max
!  AΡΧΗ
!    ΔΙΑΒΑΣΕ x , y
!    ΚΑΛΕΣΕ Μέγιστος(x , y , max)
!    ΓΡΑΨΕ max
!  ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ Σύγκριση
!
!  Και η ακόλουθη διαδικασία
!
!  ΔΙΑΔΙΚΑΣΙΑ Μέγιστος(Α , Β)
!  ΜΕΤΑΒΛΗΤΕΣ
!    ΠΡΑΓΜΑΤΙΚΕΣ : Α , Β
!    ΑΚΕΡΑΙΕΣ : Γ
!  ΑΡΧΗ
!    Γ <-- Α
!    ΑΝ Α < Β  ΤΟΤΕ
!      Γ <-- Β
!   ΤΕΛΟΣ_ΑΝ
!  ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ
!
! 1. Να γράψετε στο τετράδιό σας τα λάθη που υπάρχουν στις
!    προηγούμενες εντολές παραθέτοντας κατάλληλη τεκμηρίωση.
! 2. Να γράψετε στο τετράδιό σας διορθωμένα το ανωτέρω πρόγραμμα
!    και τη διαδικασία αυτού.
! ===============================================================
!
! ==================== ΣΥΝΤΑΚΤΙΚΑ ΛΑΘΗ ==========================
! 1. Διαφορετικό πλήθος παραμέτρων στη λίστα όταν καλείται η
!    διαδικασία και στη λίστα παραμέτρων της διαδικασίας.
! 2. Οι μεταβλητές  x και y του προγράμματος είναι ΑΚΕΡΑΙΕΣ ενώ
!    οι αντίστοιχες Α και Β της διαδικασίας είναι ΠΡΑΓΜΑΤΙΚΕΣ.
! ===============================================================

ΠΡΟΓΡΑΜΜΑ PR_2007_1C
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ : x , y , max
ΑΡΧΗ
  ΔΙΑΒΑΣΕ x , y
  ΚΑΛΕΣΕ Μέγιστος(x , y , max)
  ΓΡΑΨΕ max
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

ΔΙΑΔΙΚΑΣΙΑ Μέγιστος(Α , Β , Γ)
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ : Α , Β , Γ
ΑΡΧΗ
  Γ <-- Α
  ΑΝ Α < Β  ΤΟΤΕ
    Γ <-- Β
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters