Τώρα είναι Παρ 10 Απρ 2020 12:06 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Προσομοίωση - Θέμα 2
ΔημοσίευσηΔημοσιεύτηκε: Παρ 18 Μάιος 2007 08:22 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 12 Οκτ 2003 01:52 am
Δημοσιεύσεις: 189
Τοποθεσία: ΝΙΚΑΙΑ - ΠΕΙΡΑΙΑΣ
Syntax: [ Download ] [ Hide ]
! ===============================================================
! ΠΡΟΣΟΜΟΙΩΣΗ 2006 - ΘΕΜΑ 2
! ===============================================================
! Δίνεται το ακόλουθο τμήμα προγράμματος σε 'ΓΛΩΣΣΑ'
!
!  ΓΙΑ I ΑΠΟ 1 ΜΕΧΡΙ 3
!    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 3
!      A[i,j] <-- 0
!    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
!  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
!  ΚΑΛΕΣΕ Μαγικό_τετράγωνο(Α)
!  Sum <-- 0
!  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 3
!    Sum <-- Sum + A[i,3]
!  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
!  ΓΡΑΨΕ Sum
!
! και η διαδικασία
!
!  ΔΙΑΔΙΚΑΣΙΑ Μαγικό_τετράγωνο(Β)
!  . . . .
!  ΑΡΧΗ
!    i <-- 1
!    j <-- 4 DIV 2
!    B[i,j] <-- 1
!    ΓΙΑ key ΑΠΟ 2 ΜΕΧΡΙ 9
!      ΑΝ i > 1 TOTE
!        Κ <-- i - 1
!      ΑΛΛΙΩΣ
!        Κ <-- 3
!      ΤΕΛΟΣ_ΑΝ
!      ΑΝ j > 1 TOTE
!        L <-- j - 1
!      ΑΛΛΙΩΣ
!        L <-- 2
!      ΤΕΛΟΣ_ΑΝ
!      ΑΝ B[K,L] > 0 TOTE
!        i <-- i + 1
!        ΑN i = 4 ΤΟΤΕ
!          i <-- 1
!        ΤΕΛΟΣ_ΑΝ
!      ΑΛΛΙΩΣ
!        i <-- K
!        j <-- L
!      ΤΕΛΟΣ_ΑΝ
!      B[i,j] <-- Key
!    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
!  ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ
!
!  α) Να σχεδιάσετε στο τετράδιό σας τον πίνακα Α με τις τιμές
!     που θα έχουν τα στοιχεία του, μετά την εκτέλεση του ανωτέρω
!     τμήματος προγράμματος.
!  β) Να γράψετε στο τετράδιό σας την τιμή της μεταβλητής Sum
!     που τυπώνεται.
! ===============================================================
!
ΠΡΟΓΡΑΜΜΑ PR_2006_2
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ : i , j , A[3,3] , Sum
ΑΡΧΗ
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 3
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 3
      A[i,j] <-- 0
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ                          
  ΚΑΛΕΣΕ Μαγικό_τετράγωνο(A)
  Sum <-- 0
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 3
    Sum <-- Sum + A[i,3]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ Sum
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

ΔΙΑΔΙΚΑΣΙΑ Μαγικό_τετράγωνο(B)
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ : i , j , B[3,3] , key , K , L
ΑΡΧΗ
  i <-- 1
  j <-- 4 DIV 2
  B[i,j] <-- 1
  ΓΙΑ key ΑΠΟ 2 ΜΕΧΡΙ 9
    ΑΝ i > 1 ΤΟΤΕ
      K <-- i - 1
    ΑΛΛΙΩΣ
      K <-- 3
    ΤΕΛΟΣ_ΑΝ
    ΑΝ j > 1 ΤΟΤΕ
      L <-- j - 1
    ΑΛΛΙΩΣ
      L <-- 2
    ΤΕΛΟΣ_ΑΝ
    ΑΝ B[K,L] > 0 ΤΟΤΕ
      i <-- i + 1
      ΑΝ i = 4 ΤΟΤΕ
        i <-- 1
      ΤΕΛΟΣ_ΑΝ
    ΑΛΛΙΩΣ
      i <-- K
      j <-- L
    ΤΕΛΟΣ_ΑΝ
    B[i,j] <-- Key
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ
 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
Προβολές σελίδων: website counters