Τώρα είναι Τρί 07 Ιούλ 2020 09:00 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Πέμ 12 Απρ 2007 04:30 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 12 Οκτ 2003 01:52 am
Δημοσιεύσεις: 189
Τοποθεσία: ΝΙΚΑΙΑ - ΠΕΙΡΑΙΑΣ
Syntax: [ Download ] [ Hide ]
! ===============================================================================================
! ΕΣΠΕΡΙΝΟ - ΙΟΥΛΙΟΣ 2006 - ΘΕΜΑ 2
! ===============================================================================================
! Δίνεται το παρακάτω τμήμα αλγορίθμου:
!
!      Διάβασε Μ
!      Για Χ από 3 μέχρι Μ-1 με_βήμα 2
!         Α <-- 2*Χ + 4
!         Β <-- 4*Χ - 3
!         Αν (Β - Α < 0) ή (Α > 15) τότε
!            Α <-- Α + 5
!            Β <-- Β * 2
!         Τέλος_αν
!         Εμφάνισε Α, Β
!      Τέλος_επανάληψης
!
! Να γράψετε στο τετράδιό σας τις τιμές των μεταβλητών Α και Β που εμφανίζονται κατά την εκτέλεση
! του παραπάνω τμήματος αλγορίθμου, όταν για Μ δώσουμε την τιμή 9.
! ===============================================================================================

ΠΡΟΓΡΑΜΜΑ ES_2006_07_2
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ :Μ , Α , Β , Χ
ΑΡΧΗ
  ΔΙΑΒΑΣΕ Μ
  ΓΙΑ Χ ΑΠΟ 3 ΜΕΧΡΙ Μ-1 ΜΕ ΒΗΜΑ 2
    Α <-- 2*Χ + 4
    Β <-- 4*Χ - 3
    ΑΝ (Β - Α < 0) ή (Α > 15) ΤΟΤΕ
      Α <-- Α + 5
      Β <-- Β * 2
    ΤΕΛΟΣ_ΑΝ
    ΓΡΑΨΕ Α , Β
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση: Δεν υπάρχουν εγγεγραμμένα μέλη και 2 επισκέπτες


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters