Τώρα είναι Δευτ 10 Αύγ 2020 02:34 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Πέμ 12 Απρ 2007 04:29 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 12 Οκτ 2003 01:52 am
Δημοσιεύσεις: 189
Τοποθεσία: ΝΙΚΑΙΑ - ΠΕΙΡΑΙΑΣ
Syntax: [ Download ] [ Hide ]
! ===============================================================================================
! ΕΣΠΕΡΙΝΟ - ΙΟΥΛΙΟΣ 2006 - ΘΕΜΑ 3
! ===============================================================================================
! Ένας αγρότης παράγει ένα μόνο προϊόν από τα δύο που επιδοτούνται.
! Να γραφεί αλγόριθμος ο οποίος:
!   α) Διαβάζει το ονοματεπώνυμο του αγρότη, το είδος του προϊόντος που παράγει και την ποσότητα
!      του προϊόντος σε κιλά, ελέγχοντας την ορθότητα εισαγωγής των δεδομένων σύμφωνα με τα
!      παρακάτω:
!          - Το είδος του προϊόντος είναι Α ή Β.
!          - Η ποσότητα του προϊόντος είναι θετικός αριθμός.
!   β) Υπολογίζει την επιδότηση που δικαιούται ο αγρότης για το είδος του προϊόντος που παράγει.
!      Η επιδότηση υπολογίζεται κλιμακωτά ανάλογα με την ποσότητα και το είδος του προϊόντος
!      σύμφωνα με τον παρακάτω πίνακα:
!
!           Ποσότητα προϊόντος σε κιλά            Επιδότηση ανά κιλό προϊόντος σε ευρώ
!                                                         Προϊόν Α      Προϊόν Β
!                έως και 1.000                               0,8           0,7
!           από 1.001 έως και 2.500                          0,7           0,6
!              από 2.501 και άνω                             0,6           0,5
!
!  γ) Εμφανίζει το ονοματεπώνυμο του αγρότη, το είδος του προϊόντος που παράγει και το ποσό
!     της επιδότησης που δικαιούται.
! ===============================================================================================

ΠΡΟΓΡΑΜΜΑ ES_2006_07_3
ΜΕΤΑΒΛΗΤΕΣ

  ΠΡΑΓΜΑΤΙΚΕΣ : ποσ , επιδ
  ΧΑΡΑΚΤΗΡΕΣ : ονομα , πρ
ΑΡΧΗ
  ΓΡΑΨΕ 'Δώσε το ονοματεπώνυμο του αγρότη'
  ΔΙΑΒΑΣΕ ονομα
  ΓΡΑΨΕ 'Ποιο προϊόν παράγει Α ή Β'
  ΔΙΑΒΑΣΕ πρ                                                                                                                                    
  ΟΣΟ πρ <> 'Α' ΚΑΙ πρ <> 'Β' ΕΠΑΝΑΛΑΒΕ
    ΓΡΑΨΕ 'Λάθος. Ξαναδώσε Α ή Β ;'
    ΔΙΑΒΑΣΕ πρ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ 'Σε ποια ποσότητα (κιλά);'
  ΔΙΑΒΑΣΕ ποσ
  ΟΣΟ ποσ <= 0 ΕΠΑΝΑΛΑΒΕ
    ΓΡΑΨΕ 'Λάθος. Ξαναδώσε'
    ΔΙΑΒΑΣΕ ποσ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΑΝ ποσ <= 1000 ΤΟΤΕ
    ΑΝ πρ = 'Α' ΤΟΤΕ
      επιδ <-- 0.8*ποσ
    ΑΛΛΙΩΣ
      επιδ <-- 0.7*ποσ
    ΤΕΛΟΣ_ΑΝ
  ΑΛΛΙΩΣ_ΑΝ ποσ <= 2500 ΤΟΤΕ
    ΑΝ πρ = 'Α' ΤΟΤΕ
      επιδ <-- 0.8*1000 + (ποσ-1000)*0.7
    ΑΛΛΙΩΣ
      επιδ <-- 0.7*1000 + (ποσ-1000)*0.6
    ΤΕΛΟΣ_ΑΝ
  ΑΛΛΙΩΣ
    ΑΝ πρ = 'Α' ΤΟΤΕ
      επιδ <-- 0.8*1000 + 0.7*1500 + (ποσ-2500)*0.6
    ΑΛΛΙΩΣ
      επιδ <-- 0.7*1000 + 0.6*1500 + (ποσ-2500)*0.5
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΑΝ
  ΓΡΑΨΕ 'Ο Αγρότης :',ονομα,'παράγει το προϊόν',πρ
  ΓΡΑΨΕ 'και δικαιούται επιδότηση',επιδ,'EURO'
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters