Τώρα είναι Δευτ 10 Αύγ 2020 02:29 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Εσπερινό - Θέμα 2
ΔημοσίευσηΔημοσιεύτηκε: Τετ 11 Απρ 2007 07:05 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 12 Οκτ 2003 01:52 am
Δημοσιεύσεις: 189
Τοποθεσία: ΝΙΚΑΙΑ - ΠΕΙΡΑΙΑΣ
Syntax: [ Download ] [ Hide ]
! ===============================================================================================
! ΕΣΠΕΡΙΝΟ - ΙΟΥΝΙΟΣ 2006 - ΘΕΜΑ 2
! ===============================================================================================
! Δίνεται το παρακάτω τμήμα αλγορίθμου:
!   Χ <-- 2
!   OΣΟ Χ <= 12 ΕΠΑΝΑΛΑΒΕ
!     Y <-- X + 1
!     Z <-- Y*2
!     W <-- Z - Y + 1
!     ΕΠΙΛΕΞΕ W
!       ΠΕΡΙΠΤΩΣΗ 4
!         ΕΜΦΑΝΙΣΕ Y, Z
!       ΠΕΡΙΠΤΩΣΗ 5
!         ΕΜΦΑΝΙΣΕ Z
!       ΠΕΡΙΠΤΩΣΗ 7
!         ΕΜΦΑΝΙΣΕ X, Y
!       ΠΕΡΙΠΤΩΣΗ ΑΛΛΙΩΣ
!         ΕΜΦΑΝΙΣΕ Y, Z, W
!       ΤΕΛΟΣ_ΕΠΙΛΟΓΩΝ
!       Χ <-- X + 3
!    TEΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
!
! α. Ποιο είναι το πλήθος των επαναλήψεων που θα εκτελεστούν;
! β. Ποιες είναι οι τιμές των μεταβλητών που θα εμφανιστούν σε κάθε επανάληψη;
! γ. Ποια είναι η τελική τιμή της μεταβλητής Χ;
! ===============================================================================================

ΠΡΟΓΡΑΜΜΑ ΕΣ_2006_06_2
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ : x , y , z , w
ΑΡΧΗ
  x <-- 2
  ΓΡΑΨΕ '***************'
  ΟΣΟ x <= 12 ΕΠΑΝΑΛΑΒΕ
    y <-- x + 1
    z <-- y*2
    w <-- z - y + 1
    ΕΠΙΛΕΞΕ w
      ΠΕΡΙΠΤΩΣΗ 4
        ΓΡΑΨΕ y, z
      ΠΕΡΙΠΤΩΣΗ 5
        ΓΡΑΨΕ z
      ΠΕΡΙΠΤΩΣΗ 7
        ΓΡΑΨΕ x , y
      ΠΕΡΙΠΤΩΣΗ ΑΛΛΙΩΣ
        ΓΡΑΨΕ y , z , w
    ΤΕΛΟΣ_ΕΠΙΛΟΓΩΝ
    x <-- x + 3
    ΓΡΑΨΕ '***************'
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ 'Τελική τιμή του x =',x
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters