Τώρα είναι Σάβ 29 Φεβ 2020 03:41 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Ημερήσιο - Θέμα 2Α
ΔημοσίευσηΔημοσιεύτηκε: Τρί 10 Απρ 2007 03:14 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 12 Οκτ 2003 01:52 am
Δημοσιεύσεις: 189
Τοποθεσία: ΝΙΚΑΙΑ - ΠΕΙΡΑΙΑΣ
Syntax: [ Download ] [ Hide ]
! ===============================================================================================
! ΗΜΕΡΗΣΙΟ - ΜΑΙΟΣ 2006 - ΘΕΜΑ 2Α
! ===============================================================================================
! Δίνεται ο παρακάτω αλγόριθμος σε μορφή διαγράμματος ροής:
!
!
! α. Να κατασκευάσετε ισοδύναμο αλγόριθμο σε ψευδογλώσσα.
! β. Να εκτελέσετε τον αλγόριθμο για κάθε μία από τις παρακάτω τιμές της μεταβλητής Χ.
!    Να γράψετε στο τετράδιό σας την τιμή της μεταβλητής Υ, όπως θα εμφανισθεί σε κάθε περίπτωση.
!      i. Χ = 9
!     ii. Χ = 10
!    iii. Χ = 40
! ===============================================================================================


ΠΡΟΓΡΑΜΜΑ ΗΜ_2005_05_2Α
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ : x , y
ΑΡΧΗ
  ΓΡΑΨΕ 'Δώσε x'
  ΔΙΑΒΑΣΕ x
  ΑΝ x MOD 2 = 0 ΤΟΤΕ
    y <-- x DIV 2
    ΑΝ y <= 10 ΤΟΤΕ
      y <-- 2*x + y
    ΤΕΛΟΣ_ΑΝ
  ΑΛΛΙΩΣ
    y <-- Α_Μ(x^2)
  ΤΕΛΟΣ_ΑΝ
  ΓΡΑΨΕ y
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
Προβολές σελίδων: website counters