Τώρα είναι Δευτ 24 Ιουν 2019 07:15 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Τρί 10 Απρ 2007 03:10 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 12 Οκτ 2003 01:52 am
Δημοσιεύσεις: 189
Τοποθεσία: ΝΙΚΑΙΑ - ΠΕΙΡΑΙΑΣ
Syntax: [ Download ] [ Hide ]
! ===============================================================================================
! ΗΜΕΡΗΣΙΟ - ΙΟΥΛΙΟΣ 2006 - ΘΕΜΑ 2
! ===============================================================================================
! Δίνεται το παρακάτω πρόγραμμα και υποπρογράμματα:
!     ΠΡΟΓΡΑΜΜΑ Κλήση_Υποπρογραμμάτων
!     ΜΕΤΑΒΛΗΤΕΣ
!       ΑΚΕΡΑΙΕΣ: α, β, χ
!     ΑΡΧΗ
!       α <-- 1
!       β <-- 2
!       ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
!         ΑΝ α <= 4 ΤΟΤΕ
!           ΚΑΛΕΣΕ διαδ1(α, β, χ)
!         ΑΛΛΙΩΣ
!           χ <-- Συν1(α, β)
!        ΤΕΛΟΣ_ΑΝ
!        ΓΡΑΨΕ α, β, χ
!      ΜΕΧΡΙΣ_ΟΤΟΥ χ > 11
!      ΓΡΑΨΕ χ
!    ΤΕΛΟΣ ΠΡΟΓΡΑΜΜΑΤΟΣ
! -------------------------------------------
!    ΔΙΑΔΙΚΑΣΙΑ διαδ1 (λ, κ, μ)
!    ΜΕΤΑΒΛΗΤΕΣ
!      ΑΚΕΡΑΙΕΣ: κ, λ, μ
!    ΑΡΧΗ
!      κ <-- κ + 1
!      λ <-- λ + 3
!      μ <-- κ + λ
!    ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ
! -------------------------------------------
!    ΣΥΝΑΡΤΗΣΗ Συν1(ε, ζ): ΑΚΕΡΑΙΑ
!    ΜΕΤΑΒΛΗΤΕΣ
!      ΑΚΕΡΑΙΕΣ: ε, ζ
!    ΑΡΧΗ
!      ζ <-- ζ + 2
!      ε <-- ε*2
!      Συν1 <--  ε+ζ
!    ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ
!
! Να γράψετε στο τετράδιό σας τις τιμές που θα εμφανιστούν κατά την εκτέλεση του προγράμματος.
! ===============================================================================================

ΠΡΟΓΡΑΜΜΑ ΗΜ_2006_07_2
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: α, β, χ
ΑΡΧΗ
  α <--  1
  β <--  2
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ                      
    ΑΝ α <= 4 ΤΟΤΕ
      ΚΑΛΕΣΕ διαδ1(α, β, χ)
    ΑΛΛΙΩΣ
      χ <--  Συν1(α, β)
    ΤΕΛΟΣ_ΑΝ
    ΓΡΑΨΕ α, β, χ
  ΜΕΧΡΙΣ_ΟΤΟΥ χ > 11
  ΓΡΑΨΕ χ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

! ----------------------------

ΔΙΑΔΙΚΑΣΙΑ διαδ1 (λ, κ, μ)
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: κ, λ, μ
ΑΡΧΗ
  κ <--  κ + 1
  λ <--  λ + 3
  μ <--  κ + λ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

! ----------------------------

ΣΥΝΑΡΤΗΣΗ Συν1(e, ζ): ΑΚΕΡΑΙΑ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: e, ζ
ΑΡΧΗ
  ζ <-- ζ + 2
  e <-- e*2
  Συν1 <-- e + ζ
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ
 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters