Τώρα είναι Τρί 23 Ιούλ 2019 06:33 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Ημερήσιο - Θέμα 3
ΔημοσίευσηΔημοσιεύτηκε: Σάβ 07 Απρ 2007 04:57 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 12 Οκτ 2003 01:52 am
Δημοσιεύσεις: 189
Τοποθεσία: ΝΙΚΑΙΑ - ΠΕΙΡΑΙΑΣ
Syntax: [ Download ] [ Hide ]
! ===============================================================================================
! ΗΜΕΡΗΣΙΟ - ΜΑΙΟΣ 2006 - ΘΕΜΑ 3
! ===============================================================================================
! Σε ένα διαγωνισμό του ΑΣΕΠ εξετάζονται 1.500 υποψήφιοι. Ως εξεταστικό κέντρο χρησιμοποιείται
! ένα κτίριο με αίθουσες διαφορετικής χωρητικότητας. Ο αριθμός των επιτηρητών που απαιτούνται ανά
! αίθουσα καθορίζεται αποκλειστικά με βάση τη χωρητικότητα της αίθουσας ως εξής:
!
!             ΧΩΡΗΤΙΚΟΤΗΤΑ                ΑΡΙΘΜΟΣ ΕΠΙΤΗΡΗΤΩΝ
!           Μέχρι και 15 θέσεις                   1
!       Από 16 μέχρι και 23 θέσεις                2
!           Πάνω από 23 θέσεις                    3
!
! Να γίνει πρόγραμμα σε γλώσσα προγραμματισμού "ΓΛΩΣΣΑ" το οποίο:
! α. για κάθε αίθουσα θα διαβάζει τη χωρητικότητά της, θα υπολογίζει και θα εμφανίζει τον αριθμό
!    των επιτηρητών που χρειάζονται. Ο υπολογισμός του αριθμού των επιτηρητών να γίνεται από
!    συνάρτηση που θα κατασκευάσετε για το σκοπό αυτό.
! β. θα σταματάει όταν εξασφαλισθεί ο απαιτούμενος συνολικός αριθμός θέσεων.
!
! Σημείωση: Να θεωρήσετε ότι η συνολική χωρητικότητα των αιθουσών του κτιρίου επαρκεί για τον
!           αριθμό των υποψηφίων.
! ===============================================================================================


ΠΡΟΓΡΑΜΜΑ ΗΜ_2006_05_3
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ : Ν , x , επ
ΑΡΧΗ
  Ν <-- 0
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ 'Δώσε χωρητικότητα αίθουσας'
    ΔΙΑΒΑΣΕ x
    ΑΝ 1500 - Ν < x ΤΟΤΕ     ! Στην τελευταία αίθουσα πιθανό να μη
      x <-- Ν - x            ! χρειαστεί αριθμός επιτηρητών ανάλογος
    ΤΕΛΟΣ_ΑΝ                 ! με τη χωρητικότητά της.
    επ <-- ΥΠ_ΕΠ(x)
    ΓΡΑΨΕ 'Θα χρειαστούν',επ,'επιτηρητές.'
    Ν <-- Ν + x
  ΜΕΧΡΙΣ_ΟΤΟΥ Ν >= 1500
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

ΣΥΝΑΡΤΗΣΗ ΥΠ_ΕΠ(x): ΑΚΕΡΑΙΑ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ : x
ΑΡΧΗ
  ΑΝ x <= 15 ΤΟΤΕ
    ΥΠ_ΕΠ <-- 1
  ΑΛΛΙΩΣ_ΑΝ x <=23 ΤΟΤΕ
    ΥΠ_ΕΠ <-- 2
  ΑΛΛΙΩΣ
    ΥΠ_ΕΠ <-- 3
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
Προβολές σελίδων: website counters