Τώρα είναι Δευτ 24 Ιουν 2019 07:17 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Ημερήσιο - Θέμα 4
ΔημοσίευσηΔημοσιεύτηκε: Σάβ 07 Απρ 2007 04:54 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 12 Οκτ 2003 01:52 am
Δημοσιεύσεις: 189
Τοποθεσία: ΝΙΚΑΙΑ - ΠΕΙΡΑΙΑΣ
Syntax: [ Download ] [ Hide ]
! ===============================================================================================
! ΗΜΕΡΗΣΙΟ - ΜΑΙΟΣ 2006 - ΘΕΜΑ 4
! ===============================================================================================
! Για την παρακολούθηση των θερμοκρασιών της επικράτειας κατά το μήνα Μάιο καταγράφεται κάθε μέρα
! η θερμοκρασία στις 12:00 το μεσημέρι για 20 πόλεις.
! Να σχεδιάσετε αλγόριθμο που:
! α. θα διαβάζει τα ονόματα των 20 πόλεων και τις αντίστοιχες θερμοκρασίες για κάθε μία από τις
!    ημέρες του μήνα και θα καταχωρεί τα στοιχεία σε πίνακες.
! β. θα διαβάζει το όνομα μίας πόλης και θα εμφανίζει τη μέγιστη θερμοκρασία της στη διάρκεια του
!    μήνα. Αν δεν υπάρχει η πόλη στον πίνακα, θα εμφανίζει κατάλληλα διαμορφωμένο μήνυμα.
! γ. θα εμφανίζει το πλήθος των ημερών που η μέση θερμοκρασία των 20 πόλεων ξεπέρασε τους 20 C,
!    αλλά όχι τους 30 C.

! ===============================================================================================

ΠΡΟΓΡΑΜΜΑ ΗΜ_2005_05_4
ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ : temp[20,31] , s , mo , max
  ΑΚΕΡΑΙΕΣ : i , j , Ν
  ΧΑΡΑΚΤΗΡΕΣ : name[20] , ονομα
  ΛΟΓΙΚΕΣ : flag
ΑΡΧΗ
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 20
    ΓΡΑΨΕ 'Δώσε το όνομα της πόλης',i
    ΔΙΑΒΑΣΕ name[i]
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 31
      ΓΡΑΨΕ 'Δώσε τη θερμοκρασία για την ',j,'του μηνός.'
      ΔΙΑΒΑΣΕ temp[i,j]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ 'Δώσε το όνομα της πόλης που σε ενδιαφέρει.'
  ΔΙΑΒΑΣΕ ονομα                                                                      
  i <-- 1
  flag <-- ΨΕΥΔΗΣ
  ΟΣΟ flag = ΨΕΥΔΗΣ ΚΑΙ i <= 20 ΕΠΑΝΑΛΑΒΕ
    ΑΝ ονομα = name[i] ΤΟΤΕ
      flag <-- ΑΛΗΘΗΣ
      max <-- temp[i,1]
      ΓΙΑ j ΑΠΟ 2 ΜΕΧΡΙ 31
        ΑΝ temp[i,j] > max ΤΟΤΕ
          max <-- temp[i,j]
        ΤΕΛΟΣ_ΑΝ
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      ΓΡΑΨΕ 'Μέγιστη θερμοκρασία =',max
    ΑΛΛΙΩΣ
      i <-- i + 1
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΑΝ flag = ΨΕΥΔΗΣ ΤΟΤΕ
    ΓΡΑΨΕ 'Δεν υπάρχει πόλη με τέτοιο όνομα'
  ΤΕΛΟΣ_ΑΝ
  Ν <-- 0
  ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 31
    s <-- 0
    ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 20
      s <-- s + temp[i,j]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    mo <-- s / 20
    ΑΝ mo > 20 ΚΑΙ mo <= 30 ΤΟΤΕ
      Ν <-- Ν + 1
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ 'Κατά τη διάρκεια του μήνα είχαμε',Ν,'μέρες με θερμοκρασία πάνω από 20  και μέχρι 30.'
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters