Τώρα είναι Κυρ 21 Απρ 2019 07:28 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Σάβ 07 Απρ 2007 04:50 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 12 Οκτ 2003 01:52 am
Δημοσιεύσεις: 189
Τοποθεσία: ΝΙΚΑΙΑ - ΠΕΙΡΑΙΑΣ
Syntax: [ Download ] [ Hide ]
! ===============================================================================================
! ΗΜΕΡΗΣΙΟ - ΙΟΥΛΙΟΣ 2006 - ΘΕΜΑ 4
! ===============================================================================================
! Στους προκριματικούς αγώνες ιππικού τριάθλου συμμετέχουν 16 αθλητές. Τα αγωνίσματα είναι :
! ιππική δεξιοτεχνία, υπερπήδηση εμποδίων και ελεύθερη ιππασία. Ο κάθε αθλητής βαθμολογείται
! ξεχωριστά σε κάθε ένα από τα τρία αγωνίσματα.
! Να σχεδιάσετε αλγόριθμο ο οποίος:
! α) καταχωρίζει σε πίνακα τις ονομασίες των τριών αγωνισμάτων, όπως αυτές δίνονται παραπάνω.
! β) διαβάζει για κάθε αθλητή όνομα, επίθετο, όνομα αλόγου με το οποίο αγωνίζεται και τους
!    βαθμούς του σε κάθε αγώνισμα και θα καταχωρίζει τα στοιχεία σε πίνακες.
! γ) διαβάζει το όνομα και το επίθετο ενός αθλητή και θα εμφανίζει το όνομα του αλόγου με το
!    οποίο αγωνίστηκε και τη συνολική του βαθμολογία στα τρία αγωνίσματα. Αν δεν υπάρχει ο αθλητής,
!    θα εμφανίζει κατάλληλα διαμορφωμένο μήνυμα.
! δ) εμφανίζει την ονομασία του αγωνίσματος (ή των αγωνισμάτων) με το μεγαλύτερο "άνοιγμα
!    βαθμολογίας". Ως "άνοιγμα βαθμολογίας" να θεωρήσετε τη διαφορά ανάμεσα στην καλύτερη και
!    στη χειρότερη βαθμολογία του αγωνίσματος.
! ===============================================================================================

ΠΡΟΓΡΑΜΜΑ ΗΜ_2006_07_4
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ :i,j
  ΠΡΑΓΜΑΤΙΚΕΣ : b[16,3] , s , min , max , d[3]
  ΧΑΡΑΚΤΗΡΕΣ : a[3] , αθλ[16,3] , ονομ , επιθ
  ΛΟΓΙΚΕΣ : flag                                                              
ΑΡΧΗ
  a[1] <-- 'Ιππική δεξιοτεχνία'
  a[2] <-- 'Υπερπήδηση εμποδίων'
  a[3] <-- 'Ελέυθερη ιππασία'
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 16
    ΓΡΑΨΕ 'Δώσε όνομα, επίθετο, όνομα αλόγου του αθλητή.',i
    ΔΙΑΒΑΣΕ αθλ[i,1],αθλ[i,2],αθλ[i,3]
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 3
      ΓΡΑΨΕ 'Δώσε τη βαθμολογία του στο αγώνισμα',a[j]
      ΔΙΑΒΑΣΕ b[i,j]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ 'Δώσε όνομα και επίθετο του αθλητή που ψάχνεις'
  ΔΙΑΒΑΣΕ ονομ, επιθ
  flag <-- ΨΕΥΔΗΣ
  i <-- 1
  ΟΣΟ i <= 16 ΚΑΙ flag = ΨΕΥΔΗΣ ΕΠΑΝΑΛΑΒΕ
    ΑΝ ονομ = αθλ[i,1] ΚΑΙ επιθ = αθλ[i,2] ΤΟΤΕ
      s <-- b[i,1] + b[i,2] + b[i,3]
      ΓΡΑΨΕ 'Αγωνίστηκε με το άλογο', αθλ[i,2], 'και πήρε συνολικά',s,'βαθμούς.'
    ΑΛΛΙΩΣ
      i <-- i + 1
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΑΝ flag = ΨΕΥΔΗΣ ΤΟΤΕ
    ΓΡΑΨΕ 'Δεν αγωνίστηκε αθλητής με τέτοια στοιχεία.'
  ΤΕΛΟΣ_ΑΝ
  ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 3
    max <-- b[1,j]
    min <-- b[1,j]
    ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 16
      ΑΝ b[1,j] > max ΤΟΤΕ
        max <-- b[1,j]
      ΤΕΛΟΣ_ΑΝ
      ΑΝ B[1,j] < min ΤΟΤΕ
        min <-- b[1,j]
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    d[j] <-- max - min
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  max <-- d[1]
  ΑΝ d[2] > max ΤΟΤΕ
    max <-- d[2]
  ΤΕΛΟΣ_ΑΝ
  ΑΝ d[3] > max ΤΟΤΕ
    max <-- d[3]
  ΤΕΛΟΣ_ΑΝ
  ΓΡΑΨΕ 'Μεγαλύτερο άνοιγμα παρατηρήθηκε '
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 3
    ΑΝ d[i] = max ΤΟΤΕ
      ΓΡΑΨΕ a[i]
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters