Τώρα είναι Τρί 18 Ιουν 2019 11:53 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Προσομοίωση - Θέμα 1Δ
ΔημοσίευσηΔημοσιεύτηκε: Παρ 18 Μάιος 2007 08:25 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 12 Οκτ 2003 01:52 am
Δημοσιεύσεις: 189
Τοποθεσία: ΝΙΚΑΙΑ - ΠΕΙΡΑΙΑΣ
Syntax: [ Download ] [ Hide ]
! ===============================================================
! ΠΡΟΣΟΜΟΙΩΣΗ 2006 - ΘΕΜΑ 1Δ
! ===============================================================
! Δίνεται το παρακάτω τμήμα προγράμματος :
!
!  Sum <-- 0
!  E <-- 10
!  ΟΣΟ Ε <= 40 ΕΠΑΝΑΛΑΒΕ
!     ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 5
!        Sum <-- Sum + i
!     ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
!     ΓΡΑΨΕ Sum
!     E <-- E + 5
!  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
!
! 1. Να μετατραπεί σε ισοδύναμο με αποκλειστική χρήση της δομής
!    ΟΣΟ &#8230; ΕΠΑΝΑΛΑΒΕ
! 2. Να μετατραπεί σε ισοδύναμο με αποκλειστική χρήση της δομής
!    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ &#8230; ΜΕΧΡΙΣ_ΟΤΟΥ
! ===============================================================
!
!
ΠΡΟΓΡΑΜΜΑ PR_2007_1Δ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ : i , Sum , E
ΑΡΧΗ
  Sum <-- 0
  E <-- 10
  ΟΣΟ E <= 40 ΕΠΑΝΑΛΑΒΕ
    i <-- 1
    ΟΣΟ i <= 5 ΕΠΑΝΑΛΑΒΕ   !   ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
      Sum <-- Sum + i
      i <-- i + 1
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ       !   ΜΕΧΡΙΣ_ΟΤΟΥ i > 5
    ΓΡΑΨΕ Sum
    E <-- E + 5
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters