Τώρα είναι Δευτ 24 Ιουν 2019 07:27 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 5 Δημοσιεύσεις ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Δευτ 16 Απρ 2007 12:09 am 
Χωρίς σύνδεση

Εγγραφή: Κυρ 12 Οκτ 2003 01:52 am
Δημοσιεύσεις: 189
Τοποθεσία: ΝΙΚΑΙΑ - ΠΕΙΡΑΙΑΣ
Syntax: [ Download ] [ Hide ]
! ===============================================================================================
! ΗΜΕΡΗΣΙΟ - ΙΟΥΛΙΟΣ 2005 - ΘΕΜΑ 3
! ===============================================================================================
! Εκατό (100) υποψήφιοι του ΑΣΕΠ διαγωνίζονται σε τρία μαθήματα για την κάλυψη θέσεων στο Δημόσιο.
! Να γραφεί κύριο πρόγραμμα σε ΓΛΩΣΣΑ που να κάνει τα παρακάτω :
!   α) Διαβάζει τα ονόματα των 100 υποψηφίων του ΑΣΕΠ και τη βαθμολογία καθενός υποψηφίου σε τρία
!      διαφορετικά μαθήματα. (Θεωρήστε ότι η βαθμολογία κάθε μαθήματος είναι από 1 έως 20).
!   β) Βρίσκει και τυπώνει τον ελάχιστο και το μέγιστο βαθμό καθενός υποψηφίου στα τρία μαθήματα
!      που εξετάστηκε.
!   γ) Να γραφεί υποπρόγραμμα, το οποίο να καλείται από το κύριο πρόγραμμα, για τον υπολογισμό και
!      την εκτύπωση του μέσου όρου κάθε υποψηφίου στα τρία μαθήματα που διαγωνίστηκε.
! ===============================================================================================


ΠΡΟΓΡΑΜΜΑ ΗΜ_2005_07_3
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ : i , j
  ΠΡΑΓΜΑΤΙΚΕΣ : b[100,3] , mo , max , min
  ΧΑΡΑΚΤΗΡΕΣ : name[100]
ΑΡΧΗ
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 100
    ΓΡΑΨΕ 'Δώσε το όνομα του υποψηφίου Νο :', i
    ΔΙΑΒΑΣΕ name[i]
    ΓΡΑΨΕ 'Δώσε τους βαθμούς του στα τρία μαθήματα που εξετάστηκε.'
    ΔΙΑΒΑΣΕ b[i,1] , b[i,2] , b[i,3]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 100
    max <-- 0
    min <-- 21
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 3
      ΑΝ b[i,j] > max ΤΟΤΕ
        max <-- b[i,j]
      ΤΕΛΟΣ_ΑΝ
      ΑΝ b[i,j] < min ΤΟΤΕ
        min <-- b[i,j]
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ '==========================='
    ΓΡΑΨΕ name[i]
    ΓΡΑΨΕ '==========================='
    ΓΡΑΨΕ 'Μικρότερος βαθμός  =', min
    ΓΡΑΨΕ 'Μεγαλύτερος βαθμός =', max
    ΓΡΑΨΕ '==========================='
    ΓΡΑΨΕ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΚΑΛΕΣΕ DIAD(name , b)

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

! ===== ΔΙΑΔΙΚΑΣΙΑ =============

ΔΙΑΔΙΚΑΣΙΑ DIAD(table1 , table2)
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ : x, i
  ΠΡΑΓΜΑΤΙΚΕΣ : table2[100,3] , s , mo                                    
  ΧΑΡΑΚΤΗΡΕΣ : table1[100]  
ΑΡΧΗ
  ΓΙΑ x ΑΠΟ 1 ΜΕΧΡΙ 100
    mo <-- (table2[x,1] + table2[x,1] + table2[x,1])/3
    ΓΡΑΨΕ table1[i] , 'Mέσος όρος βαθμολογίας =', mo
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ
 


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης:
ΔημοσίευσηΔημοσιεύτηκε: Τετ 16 Μάιος 2007 11:49 am 
Χωρίς σύνδεση

Εγγραφή: Τετ 16 Μάιος 2007 11:43 am
Δημοσιεύσεις: 2
Τοποθεσία: ΘΕΣΣΑΛΟΝΙΚΗ
Γειά σας
Θα ήθελα να σας ρωτ'ησω σχετικά με τη κλήση υποπρογράμματος οπου στις παραμέτρους υπάρχει πίνακας.
Στο τετράδιο μαθητή του οργανισμού λέει οτι ο πίνακας καλείται με το όνομά του και με μια παράμετρο που δίνει το πλήθος των στοιχείων του.
Πόσο σωστό είναι να καλούμε έναν πίνακα μόνο με το όνομά του; Μήπως υπάρχει πρόβλημα με αυτό τον τρόπο κλήσης;


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης:
ΔημοσίευσηΔημοσιεύτηκε: Τετ 16 Μάιος 2007 12:21 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 12 Οκτ 2003 01:52 am
Δημοσιεύσεις: 189
Τοποθεσία: ΝΙΚΑΙΑ - ΠΕΙΡΑΙΑΣ
Η λίστα παραμέτρων στην κλήση του υποπρογράμματος πρέπει να είναι σε πλήρη αντιστοιχία με τη λίστα παραμέτρων του υποπρογράμματος.
Αυτό σημαίνει ότι κάθε μεταβλητή που αναφέρεται στην κλήση έχει την αντίστοιχή της στο υποπρόγραμμα, που μπορεί να έχει άλλο όνομα αλλά πρέπει να είναι του ίδιου τύπου και αν είναι πίνακας να είναι και του ίδιου μεγέθους.
Συνεπώς το όνομα του πίνακα είναι αρκετό στην κλήση.
Βέβαια αν θέλουμε να επεξεργαστούμε ένα μέρος του πίνακα θα χρειαστεί να στείλουμε μέσω μιας μεταβλητής και ένα νούμερο ακόμα σχετικά με το πλήθος των θέσεων που θα επεξεργαστούμε.


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης:
ΔημοσίευσηΔημοσιεύτηκε: Τετ 16 Μάιος 2007 02:10 pm 
Χωρίς σύνδεση

Εγγραφή: Τετ 16 Μάιος 2007 11:43 am
Δημοσιεύσεις: 2
Τοποθεσία: ΘΕΣΣΑΛΟΝΙΚΗ
Συμφωνώ με αυτά που λέτε, αλλά με τον τρόπο σας αλλάζουμε τον τρόπο κλήσης ενός υποπρογράμματος σύμφωνα με το επίσημο βιβλίο των μαθητών. Μήπως έτσι τους μπερδεύουμε;


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης:
ΔημοσίευσηΔημοσιεύτηκε: Πέμ 17 Μάιος 2007 11:26 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 12 Οκτ 2003 01:52 am
Δημοσιεύσεις: 189
Τοποθεσία: ΝΙΚΑΙΑ - ΠΕΙΡΑΙΑΣ
Σήμερα βρήκα χρόνο και κοίταξα το τετράδιο του μαθητή που αναφέρεις. Λέει αυτό ακριβώς που σου εξήγησα.
Ο πίνακας είναι 100 θέσεων αλλά δε είναι όλος γεμάτος. Για το λόγο αυτό στέλνεται στο υποπρόγραμμα η πληροφορία σχετικά με το πλήθος των θέσεων που πρέπει να επεξεργαστεί το υποπρόγραμμα.
Δε λέει πουθενά ότι πρέπει να στέλνουμε το μέγεθος του πίνακα στο υποπρόγραμμα.


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 5 Δημοσιεύσεις ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters