Τώρα είναι Δευτ 24 Ιουν 2019 06:36 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Εσπερινό - Θέμα 2
ΔημοσίευσηΔημοσιεύτηκε: Πέμ 12 Απρ 2007 04:23 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 12 Οκτ 2003 01:52 am
Δημοσιεύσεις: 189
Τοποθεσία: ΝΙΚΑΙΑ - ΠΕΙΡΑΙΑΣ
Syntax: [ Download ] [ Hide ]
! ===============================================================================================
! ΕΣΠΕΡΙΝΟ - ΙΟΥΝΙΟΣ 2005 - ΘΕΜΑ 2
! ===============================================================================================
! Δίνεται το παρακάτω τμήμα αλγορίθμου όπου οι μεταβλητές Κ , L , M είναι ακέραιες :!
!    K <-- 35
!    L <-- 17
!    M <-- 0
!    OΣΟ L > 0 ΕΠΑΝΑΛΑΒΕ
!       ΑΝ L MOD 2 = 1 TOTE
!          M <-- M + K
!       ΤΕΛΟΣ_ΑΝ
!       Κ <-- Κ*2
!       L <-- L DIV 2
!    TEΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
!    ΕΜΦΑΝΙΣΕ Μ
! α) Να συμπληρώσετε τον παρακάτω πίνακα :
!                    Κ  L  Μ
!    ΑΡΧΙΚΕΣ ΤΙΜΕΣ
!    1η επανάληψη
!    2η επανάληψη
!    3η επανάληψη
!    4η επανάληψη
!    5η επανάληψη
!
! β) Για ποια τιμή της μεταβλητής L τερματίζει ο αλγόριθμος;
! γ) Ποια είναι η τελική τιμή της μεταβλητής Μ;
! ===============================================================================================

ΠΡΟΓΡΑΜΜΑ ΕΣ_2005_06_2
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ : K , L , M , Ν
ΑΡΧΗ
  K <-- 35
  L <-- 17
  M <-- 0
  Ν <-- 0
  ΓΡΑΨΕ '  ==============================='
  ΓΡΑΨΕ '  ΑΡΧΙΚΕΣ ΤΙΜΕΣ'
  ΓΡΑΨΕ '  K =' , K                                                                              
  ΓΡΑΨΕ '  L =' , L
  ΓΡΑΨΕ '  M =' , M
  ΟΣΟ L > 0 ΕΠΑΝΑΛΑΒΕ
    Ν <-- Ν + 1
    ΑΝ L MOD 2 = 1 ΤΟΤΕ
      M <-- M + K
    ΤΕΛΟΣ_ΑΝ
    K <-- K*2
    L <-- L DIV 2
    ΓΡΑΨΕ '  ==============================='
    ΓΡΑΨΕ ' ' , Ν , 'η ΕΠΑΝΑΛΗΨΗ'
    ΓΡΑΨΕ '  -------------------------------'
    ΓΡΑΨΕ '  K =' , K
    ΓΡΑΨΕ '  L =' , L
    ΓΡΑΨΕ '  M =' , M
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ '  ==============================='
  ΓΡΑΨΕ '  ΤΕΛΙΚΗ ΤΙΜΗ L =',L
  ΓΡΑΨΕ '  ΤΕΛΙΚΗ ΤΙΜΗ M =',M
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters