Τώρα είναι Πέμ 27 Ιουν 2019 03:30 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Εσπερινό - Θέμα 3
ΔημοσίευσηΔημοσιεύτηκε: Πέμ 12 Απρ 2007 04:23 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 12 Οκτ 2003 01:52 am
Δημοσιεύσεις: 189
Τοποθεσία: ΝΙΚΑΙΑ - ΠΕΙΡΑΙΑΣ
Syntax: [ Download ] [ Hide ]
!===============================================================================================
! ΕΣΠΕΡΙΝΟ - ΙΟΥΝΙΟΣ 2005 - ΘΕΜΑ 3
! ===============================================================================================
! Για την εύρεση πόρων προκειμένου οι μαθητές της Δ΄ τάξης Εσπερινού Λυκείου να συμμετάσχουν σε
! εκδρομή οργανώνεται λαχειοφόρος αγορά. Οι μαθητές του Λυκείου διαθέτουν λαχνούς στα σχολεία της
! περιοχής τους. Διακόσιοι μαθητές από δεκαπέντε διαφορετικά σχολεία αγόρασαν ο καθένας από έναν
! μόνο λαχνό. Μετά από κλήρωση ένας μαθητής κερδίζει τον πρώτο λαχνό.
! Να γίνει τμήμα αλγορίθμου που
!  α) για κάθε μαθητή που αγόρασε λαχνό να εισάγει σε μονοδιάστατο πίνακα Α 200 θέσεων το επώνυμό
!     του και στην αντίστοιχη θέση μονοδιάστατου πίνακα Β 200 θέσεων το όνομα του σχολείου του,
!  β) να εισάγει σε μονοδιάστατο πίνακα Σ 15 θέσεων τα ονόματα όλων των σχολείων της περιοχής και
!     στις αντίστοιχες θέσεις μονοδιάστατου πίνακα M 15 θέσεων τις ηλεκτρονικές διευθύνσεις των
!     σχολείων,
!  γ) να διαβάζει το επώνυμο του μαθητή, που κέρδισε τον πρώτο λαχνό,
!  δ) χρησιμοποιώντας τον αλγόριθμο της σειριακής αναζήτησης να προσδιορίζει τη θέση του επωνύμου
!     του τυχερού μαθητή στον πίνακα Α. Στη συνέχεια στον πίνακα Β να βρίσκει το όνομα του
!     σχολείου που φοιτά,                                                                              
!  ε) λαμβάνοντας υπόψη το όνομα του σχολείου που φοιτά ο τυχερός μαθητής και χρησιμοποιώντας τον
!     αλγόριθμο της σειριακής αναζήτησης να προσδιορίζει την θέση του σχολείου στον πίνακα Σ.
!     Στη συνέχεια στον πίνακα M να βρίσκει τη διεύθυνση του ηλεκτρονικού ταχυδρομείου του
!     σχολείου αυτού,
! στ) να εμφανίζει το επώνυμο του τυχερού μαθητή, το όνομα του σχολείου του και τη διεύθυνση του
!     ηλεκτρονικού ταχυδρομείου του σχολείου του.
! Σημείωση : Να θεωρήσετε ότι δεν υπάρχουν μαθητές με το ίδιο επώνυμο και ότι κάθε μαθητής
!            αγόρασε ένα μόνο λαχνό.
! ===============================================================================================

ΠΡΟΓΡΑΜΜΑ ΕΣ_2005_06_3
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ : i , j
  ΧΑΡΑΚΤΗΡΕΣ : a[200] , b[200] , s[15] , m[15] , ονομα , σχολείο , e
  ΛΟΓΙΚΕΣ : βρέθηκε
ΑΡΧΗ
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 200
    ΓΡΑΨΕ 'Δώσε το όνομα του μαθητή που αγόρασε το λαχνό Νο :' , i
    ΔΙΑΒΑΣΕ a[i]
    ΓΡΑΨΕ 'Δώσε και το όνομα του σχολείου του.'
    ΔΙΑΒΑΣΕ b[i]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 15
    ΓΡΑΨΕ 'Δώσε το όνομα του σχολείου' , i
    ΔΙΑΒΑΣΕ s[i]
    ΓΡΑΨΕ 'Δώσε και την ηλεκτρονική του διεύθυνση.'
    ΔΙΑΒΑΣΕ m[i]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΡΑΨΕ 'Δώσε το όνομα του μαθητή που κέρδισε τον πρώτο λαχνό.'
  ΔΙΑΒΑΣΕ όνομα                   ! Υποθέτουμε ότι δε θα δοθεί όνομα που δεν υπάρχει στον πίνακα a.

  i <-- 1
  βρέθηκε <-- ΨΕΥΔΗΣ
  ΟΣΟ βρέθηκε = ΨΕΥΔΗΣ ΕΠΑΝΑΛΑΒΕ  ! Δε χρειάζεται ο έλεγχος i <= 200 αφού το όνομα κάπου θα βρεθεί.
    ΑΝ ονομα = a[i] ΤΟΤΕ
      βρέθηκε <-- ΑΛΗΘΗΣ
      σχολείο <-- b[i]
    ΑΛΛΙΩΣ
      i <-- i + 1
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 15
    ΑΝ s[i] = σχολείο ΤΟΤΕ
      e <-- m[i]                  ! Δεν υπάρχει περίπτωση να μη βρεθεί το όνομα του σχολείου,
      i <-- 15                    ! και ένα άλλο κόλπο για να τερματίζεται η επαναληπτική μόλις
    ΤΕΛΟΣ_ΑΝ                      ! βρεθεί αυτό που ψάχνουμε.
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΡΑΨΕ 'Ο μαθητής που κέρδισε τον πρώτο λαχνό λέγεται' , όνομα
  ΓΡΑΨΕ 'πηγαίνει στο σχολείο', σχολείο , 'που το e-mail του είναι' , e


ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters