Τώρα είναι Τετ 03 Ιουν 2020 06:48 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Ημερήσιο - Θέμα 1Γ
ΔημοσίευσηΔημοσιεύτηκε: Πέμ 12 Απρ 2007 04:19 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 12 Οκτ 2003 01:52 am
Δημοσιεύσεις: 189
Τοποθεσία: ΝΙΚΑΙΑ - ΠΕΙΡΑΙΑΣ
Syntax: [ Download ] [ Hide ]
! ===============================================================================================
! ΗΜΕΡΗΣΙΟ - ΙΟΥΝΙΟΣ 2005 - ΘΕΜΑ 1Γ
! ===============================================================================================
! Δίνεται το παρακάτω τμήμα αλγορίθμου:
!    S <-- 0
!    Για Ι από 2 μέχρι 100 με_βήμα 2
!       S <-- S + I
!    Τέλος_επανάληψης
!    Εμφάνισε S
!
! 1. Να μετατραπεί σε ισοδύναμο με χρήση της δομής Όσο &#8230; Επανάλαβε
! 2. Να μετατραπεί σε ισοδύναμο με χρήση της δομής αρχή_επανάληψης&#8230; μέχρις_ότου.
! ===============================================================================================

ΠΡΟΓΡΑΜΜΑ ΗΜ_2005_06_1Γ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ : s , i
ΑΡΧΗ
  ΓΡΑΨΕ '========== ΑΡΧΙΚΟΣ ΑΛΓΟΡΙΘΜΟΣ =========='
  S <-- 0
  ΓΙΑ I ΑΠΟ 2 ΜΕΧΡΙ 100 ΜΕ ΒΗΜΑ 2
    s <-- s + i
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ
  ΓΡΑΨΕ '          S =' , S , ' ,  I =' , i
  ΓΡΑΨΕ
  ΓΡΑΨΕ '----------------------------------------'
  ΓΡΑΨΕ
  ΓΡΑΨΕ
  ΓΡΑΨΕ '======== ΔΟΜΗ Οσο ... Επανάλαβε ========'
  s <-- 0
  i <-- 2
  ΟΣΟ i <= 100 ΕΠΑΝΑΛΑΒΕ
    s <-- s + i
    i <-- i + 2
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ
  ΓΡΑΨΕ '          S =' , s , ' ,  I =' , i
  ΓΡΑΨΕ
  ΓΡΑΨΕ '----------------------------------------'
  ΓΡΑΨΕ
  ΓΡΑΨΕ
  ΓΡΑΨΕ '= ΔΟΜΗ Αρχή_επανάληψης ... Μέχρις_ότου ='
  s <-- 0
  i <-- 2
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    s <-- s + i
    i <-- i + 2
  ΜΕΧΡΙΣ_ΟΤΟΥ i > 100
  ΓΡΑΨΕ
  ΓΡΑΨΕ '          S =' , s , ' ,  I =' , i
  ΓΡΑΨΕ
  ΓΡΑΨΕ '----------------------------------------'
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
Προβολές σελίδων: website counters