Τώρα είναι Δευτ 18 Φεβ 2019 11:06 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Ημερήσιο - Θέμα 2
ΔημοσίευσηΔημοσιεύτηκε: Πέμ 12 Απρ 2007 04:18 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 12 Οκτ 2003 01:52 am
Δημοσιεύσεις: 189
Τοποθεσία: ΝΙΚΑΙΑ - ΠΕΙΡΑΙΑΣ
Syntax: [ Download ] [ Hide ]
! ===============================================================================================
! ΗΜΕΡΗΣΙΟ - ΙΟΥΝΙΟΣ 2005 - ΘΕΜΑ 2
! ===============================================================================================
! Δίνεται το παρακάτω τμήμα προγράμματος και μια συνάρτηση :
!    Διάβασε Κ
!    L <-- 2
!    A <-- 1
!    Όσο Α < 8 επανάλαβε
!       Αν Κ MOD L = 0 τότε
!          Χ <-- Fun(A, L)
!       αλλιώς
!          Χ <-- Α + L
!       Τέλος_αν
!       Εμφάνισε L, A, X
!       A <-- A + 2
!       L <-- L + 1
!    Tέλος_επανάληψης
!    &#8230;&#8230;&#8230;&#8230;&#8230;
!    Συνάρτηση Fun(Β, Δ) : Ακέραια
!    Μεταβλητές
!    Ακέραιες: Β, Δ
!    Αρχή
!      Fun <-- (B + Δ) DIV 2
!    Tέλος_συνάρτησης.
!
! Να γράψετε στο τετράδιό σας τις τιμές των μεταβλητών L, A, X, όπως αυτές εκτυπώνονται σε κάθε
! επανάληψη, όταν για είσοδο δώσουμε την τιμή 10.
! ===============================================================================================

ΠΡΟΓΡΑΜΜΑ ΗΜ_2005_06_2
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ : L , A , K , X
ΑΡΧΗ
  ΓΡΑΨΕ 'Δώσε τιμή για το Κ'
  ΔΙΑΒΑΣΕ K
  L <-- 2
  A <-- 1
  ΟΣΟ A < 8 ΕΠΑΝΑΛΑΒΕ
    ΑΝ K MOD L = 0 ΤΟΤΕ
      X <-- Fun(A, L)
    ΑΛΛΙΩΣ
      X <-- A + L
    ΤΕΛΟΣ_ΑΝ
    ΓΡΑΨΕ L, A, X
    A <-- A + 2
    L <-- L + 1
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

ΣΥΝΑΡΤΗΣΗ Fun(Β, Δ) : ΑΚΕΡΑΙΑ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ : Β, Δ
ΑΡΧΗ
  Fun <-- (Β + Δ) DIV 2
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ
 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters