Τώρα είναι Κυρ 21 Απρ 2019 07:47 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Ημερήσιο - Θέμα 3
ΔημοσίευσηΔημοσιεύτηκε: Πέμ 12 Απρ 2007 04:17 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 12 Οκτ 2003 01:52 am
Δημοσιεύσεις: 189
Τοποθεσία: ΝΙΚΑΙΑ - ΠΕΙΡΑΙΑΣ
Syntax: [ Download ] [ Hide ]
! ===============================================================================================
! ΗΜΕΡΗΣΙΟ - ΙΟΥΝΙΟΣ 2005 - ΘΕΜΑ 3
! ===============================================================================================
! Δίνεται πίνακας Α[Ν] ακέραιων και θετικών αριθμών, καθώς και πίνακας Β[Ν-1] πραγματικών και
! θετικών αριθμών.
! Να γραφεί αλγόριθμος, ο οποίος να ελέγχει αν κάθε στοιχείο Β[i] είναι ο μέσος όρος των
! στοιχείων Α[i] και Α[i+1], δηλαδή αν Β[i] = (Α[i] + Α[i+1])/2.
! Σε περίπτωση που ισχύει, τότε να εμφανίζεται το μήνυμα "Ο πίνακας Β είναι ο τρέχων μέσος του Α",
! διαφορετικά να εμφανίζεται το μήνυμα "Ο πίνακας Β δεν είναι ο τρέχων μέσος του Α".
! Για παράδειγμα :
! Έστω ότι τα στοιχεία του πίνακα Α είναι  :   1 , 3 , 5 , 10 , 15
! και ότι τα στοιχεία του πίνακα Β είναι   :   2 , 4 , 7.5 , 12.5.
! Τότε ο αλγόριθμος θα εμφανίσει το μήνυμα "Ο πίνακας Β είναι ο τρέχων μέσος του Α", διότι
!       2 = (1+3)/2   ,   4 = (3+5)/2   ,   7.5 = (5+10)/2   ,   12.5 = (10+15)/2
! ===============================================================================================

ΠΡΟΓΡΑΜΜΑ ΗΜ_2005_06_3
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: A[5] , i
  ΠΡΑΓΜΑΤΙΚΕΣ: B[4]
  ΛΟΓΙΚΕΣ: flag
ΑΡΧΗ
  A[1] <-- 1
  A[2] <-- 3
  A[3] <-- 5
  A[4] <-- 10                                                                                                                      
  A[5] <-- 15
  B[1] <-- 2
  B[2] <-- 4
  B[3] <-- 7.5
  B[4] <-- 12.5
  flag <-- ΑΛΗΘΗΣ
  i <-- 1
  ΟΣΟ flag = ΑΛΗΘΗΣ ΚΑΙ i <= 4 ΕΠΑΝΑΛΑΒΕ
    ΑΝ B[i] = (A[i] + A[i+1])/2 ΤΟΤΕ
      i <-- i + 1
    ΑΛΛΙΩΣ
      flag <-- ΨΕΥΔΗΣ
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΑΝ flag = ΑΛΗΘΗΣ ΤΟΤΕ
    ΓΡΑΨΕ 'Ο πίνακας Β είναι ο τρέχων μέσος του Α'
  ΑΛΛΙΩΣ
    ΓΡΑΨΕ 'Ο πίνακας Β δεν είναι ο τρέχων μέσος του Α'
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters