Τώρα είναι Δευτ 18 Φεβ 2019 11:24 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Πέμ 12 Απρ 2007 04:14 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 12 Οκτ 2003 01:52 am
Δημοσιεύσεις: 189
Τοποθεσία: ΝΙΚΑΙΑ - ΠΕΙΡΑΙΑΣ
Syntax: [ Download ] [ Hide ]
! ===============================================================================================
! ΕΣΠΕΡΙΝΟ - ΙΟΥΛΙΟΣ 2005 - ΘΕΜΑ 1Ε
! ===============================================================================================
! To παρακάτω τμήμα προγράμματος να μετατραπεί σε ισοδύναμο, χρησιμοποιώντας αποκλειστικά τη δομή
! επανάληψης ΟΣΟ… ΕΠΑΝΑΛΑΒΕ.
!   S <-- 0
!   ΓΙΑ Κ από 1 μέχρι 5
!      ΓΙΑ L από 1 μέχρι 7
!         S <-- S + 1
!      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
!   ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
!   ΓΡΑΨΕ S
! ===============================================================================================

ΠΡΟΓΡΑΜΜΑ ΕΣ_2005_07_1Ε
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ : s , k , l
ΑΡΧΗ
! ============ ΑΡΧΙΚΟΣ ============
  ΓΡΑΨΕ 'O αλγόριθμος που δίνεται'
  ΓΡΑΨΕ '------------------------'
  s <-- 0
  ΓΙΑ k από 1 μέχρι 5
    ΓΙΑ l από 1 μέχρι 7
      s <-- s + 1
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ 'S =' , s , '  K =' , k , '  L =' , l
  ΓΡΑΨΕ '------------------------'
  ΓΡΑΨΕ
! =========== ΙΣΟΔΥΝΑΜΟΣ ===========
  ΓΡΑΨΕ 'O ισοδύναμος αλγόριθμος'
  ΓΡΑΨΕ '------------------------'
  s <-- 0
  k <-- 1
  ΟΣΟ k <= 5 ΕΠΑΝΑΛΑΒΕ
    l <-- 1
    ΟΣΟ l <= 7 ΕΠΑΝΑΛΑΒΕ
      s <-- s + 1                                                                                                        
      l <-- l + 1
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    k <-- k + 1
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ 'S =' , s , '  K =' , k , '  L =' , l
  ΓΡΑΨΕ '------------------------'

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters