Τώρα είναι Δευτ 26 Αύγ 2019 07:32 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Πέμ 12 Απρ 2007 04:13 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 12 Οκτ 2003 01:52 am
Δημοσιεύσεις: 189
Τοποθεσία: ΝΙΚΑΙΑ - ΠΕΙΡΑΙΑΣ
Syntax: [ Download ] [ Hide ]
! ===============================================================================================
! ΕΣΠΕΡΙΝΟ - ΙΟΥΛΙΟΣ 2005 - ΘΕΜΑ 2
! ===============================================================================================
! Να αναπτύξετε έναν αλγόριθμο, ώστε :
!  α) να διαβάζει έναν πραγματικό αριθμό μεγαλύτερο του μηδενός και μικρότερο του 1000 και
!     να κάνει έλεγχο ορθής καταχώρησης του αριθμού,
!  β) να ελέγχει αν είναι ακέραιος και να εμφανίζει τη λέξη "ΑΚΕΡΑΙΟΣ" αλλιώς
!     να εμφανίζει τη λέξη "ΠΡΑΓΜΑΤΙΚΟΣ",
!  γ) να ελέγχει, στην περίπτωση που ο αριθμός είναι ακέραιος, αν είναι άρτιος ή περιττός και
!     να εμφανίζει τη λέξη "ΑΡΤΙΟΣ" ή "ΠΕΡΙΤΤΟΣ" αντίστοιχα.
! ===============================================================================================

ΠΡΟΓΡΑΜΜΑ ΕΣ_2005_07_2
ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ : x
ΑΡΧΗ
  ΓΡΑΨΕ 'Δώσε έναν πραγματικό αριθμό μεγαλύτερο του μηδενός και μικρότερο του 1000.'
  ΔΙΑΒΑΣΕ x
  ΟΣΟ x <= 0 ή x >= 1000 ΕΠΑΝΑΛΑΒΕ
    ΓΡΑΨΕ 'Λάθος. Ξαναδώσε.'
    ΔΙΑΒΑΣΕ x
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΑΝ x = Α_Μ(x) ΤΟΤΕ
    ΓΡΑΨΕ 'ΑΚΕΡΑΙΟΣ'
    ΑΝ Α_Μ(x) MOD 2 = 0 ΤΟΤΕ
      ΓΡΑΨΕ 'ΑΡΤΙΟΣ'
    ΑΛΛΙΩΣ
      ΓΡΑΨΕ 'ΠΕΡΙΤΤΟΣ'
    ΤΕΛΟΣ_ΑΝ
  ΑΛΛΙΩΣ
    ΓΡΑΨΕ 'ΠΡΑΓΜΑΤΙΚΟΣ'
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters