Τώρα είναι Κυρ 21 Απρ 2019 07:31 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Πέμ 12 Απρ 2007 04:12 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 12 Οκτ 2003 01:52 am
Δημοσιεύσεις: 189
Τοποθεσία: ΝΙΚΑΙΑ - ΠΕΙΡΑΙΑΣ
Syntax: [ Download ] [ Hide ]
! ===============================================================================================
! ΕΣΠΕΡΙΝΟ - ΙΟΥΛΙΟΣ 2005 - ΘΕΜΑ 3
! ===============================================================================================
! Μία εμπορική εταιρεία μέσω αντιπροσώπων διαθέτει στο αγοραστικό κοινό τρεις τύπους προϊόντων
! Χ, Ψ και Ζ και χορηγεί προμήθεια στους αντιπροσώπους της.
! Να αναπτύξετε έναν αλγόριθμο, ώστε :
!  α) να διαβάζει τον τύπο ενός προϊόντος και την τιμή πώλησης αυτού,
!  β) να υπολογίζει κλιμακωτά την προμήθεια που θα δοθεί από την πώληση σύμφωνα με τον παρακάτω
!     πίνακα:
!          ==================================================================
!                                                    Ποσοστά προμήθειας
!                Τιμή πώλησης  σε  €            Προϊόν Χ  Προϊόν Ψ  Προϊόν Ζ
!          ------------------------------------------------------------------
!           Από 0 έως και 5.000                    0%        2%        4%
!           Πάνω από 5.000 έως και 10.000          5%        6%        6%
!           Πάνω  από 10.000                      10%        7%        8%
!          ==================================================================
!   Η είσοδος των δεδομένων και ο υπολογισμός της προμήθειας θα επαναλαμβάνεται μέχρι να δοθεί
!   τύπος προϊόντος Τ,
! γ) στο τέλος να εμφανίζεται
!       i. η προμήθεια που θα δοθεί για κάθε τύπο προϊόντος,
!      ii. η συνολική προμήθεια που έλαβαν οι αντιπρόσωποι.
! ===============================================================================================

ΠΡΟΓΡΑΜΜΑ ΕΣ_2005_07_3
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ : S , K , L
  ΠΡΑΓΜΑΤΙΚΕΣ : sx , sy , sz , τιμή , προμ
  ΧΑΡΑΚΤΗΡΕΣ : πρ
ΑΡΧΗ
  ΓΡΑΨΕ 'Δώσε τύπο προϊόντος ( Χ , Ψ , Ζ ή Τ για τέλος)'
  ΔΙΑΒΑΣΕ πρ
  ΟΣΟ πρ <> 'Χ' ΚΑΙ πρ <> 'Ψ' ΚΑΙ πρ <> 'Ζ' ΚΑΙ πρ <> 'Τ' ΕΠΑΝΑΛΑΒΕ
    ΓΡΑΨΕ 'Λάθος. Ξαναδώσε Χ , Ψ , Ζ ή Τ για τέλος'
    ΔΙΑΒΑΣΕ πρ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  sx <-- 0    ! Συνολική προμήθεια για το προϊόν Χ
  sy <-- 0    ! Συνολική προμήθεια για το προϊόν Ψ
  sz <-- 0    ! Συνολική προμήθεια για το προϊόν Ζ

  ΟΣΟ πρ <> 'Τ' ΕΠΑΝΑΛΑΒΕ
    ΓΡΑΨΕ 'Δώσε την τιμή πώλησής του.'
    ΔΙΑΒΑΣΕ τιμή

    ΑΝ πρ = 'Χ' ΤΟΤΕ
      ΑΝ τιμή <= 5000 ΤΟΤΕ
        προμ <-- 0
      ΑΛΛΙΩΣ_ΑΝ τιμή <= 10000 ΤΟΤΕ
        προμ <-- (τιμή-5000)*5/100
      ΑΛΛΙΩΣ
        προμ <-- 5000*5/100 + (τιμή-10000)*10/100
      ΤΕΛΟΣ_ΑΝ
      sx <-- sx + προμ

    ΑΛΛΙΩΣ_ΑΝ πρ = 'Ψ' ΤΟΤΕ
      ΑΝ τιμή <= 5000 ΤΟΤΕ
        προμ <-- τιμή*2/100
      ΑΛΛΙΩΣ_ΑΝ τιμή <= 10000 ΤΟΤΕ
        προμ <-- 5000*2/100 + (τιμή-5000)*6/100
      ΑΛΛΙΩΣ
        προμ <-- 5000*2/100 + 5000*6/100 + (τιμή-10000)*7/100
      ΤΕΛΟΣ_ΑΝ
      sy <-- sy + προμ

    ΑΛΛΙΩΣ
      ΑΝ τιμή <= 5000 ΤΟΤΕ
        προμ <-- τιμή*4/100
      ΑΛΛΙΩΣ_ΑΝ τιμή <= 10000 ΤΟΤΕ
        προμ <-- 5000*4/100 + (τιμή-5000)*6/100
      ΑΛΛΙΩΣ
        προμ <-- 5000*4/100 + 5000*6/100 + (τιμή-10000)*8/100
      ΤΕΛΟΣ_ΑΝ
      sz <-- sz + προμ

    ΤΕΛΟΣ_ΑΝ

    ΓΡΑΨΕ 'Δώσε τύπο προϊόντος ( Χ , Ψ , Ζ ή Τ για τέλος)'
    ΔΙΑΒΑΣΕ πρ
    ΟΣΟ πρ <> 'Χ' ΚΑΙ πρ <> 'Ψ' ΚΑΙ πρ <> 'Ζ' ΚΑΙ πρ <> 'Τ' ΕΠΑΝΑΛΑΒΕ
      ΓΡΑΨΕ 'Λάθος. Ξαναδώσε Χ , Ψ , Ζ ή Τ για τέλος'
      ΔΙΑΒΑΣΕ πρ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΡΑΨΕ '-------------------------------------'
  ΓΡΑΨΕ 'Προϊόν Χ. ΣΥΝΟΛΙΚΗ ΠΡΟΜΗΘΕΙΑ =' , sx
  ΓΡΑΨΕ 'Προϊόν Ψ. ΣΥΝΟΛΙΚΗ ΠΡΟΜΗΘΕΙΑ =' , sy
  ΓΡΑΨΕ 'Προϊόν Ζ. ΣΥΝΟΛΙΚΗ ΠΡΟΜΗΘΕΙΑ =' , sz
  ΓΡΑΨΕ '-------------------------------------'
  ΓΡΑΨΕ '                 Σ Υ Ν Ο Λ Ο =' , sx + sy + sz
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters