Τώρα είναι Δευτ 18 Φεβ 2019 10:44 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Πέμ 12 Απρ 2007 03:57 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 12 Οκτ 2003 01:52 am
Δημοσιεύσεις: 189
Τοποθεσία: ΝΙΚΑΙΑ - ΠΕΙΡΑΙΑΣ
Syntax: [ Download ] [ Hide ]
! ===============================================================================================
! ΗΜΕΡΗΣΙΟ - ΙΟΥΛΙΟΣ 2005 - ΘΕΜΑ 2Α
! ===============================================================================================
! Δίνεται το παρακάτω πρόγραμμα το οποίο διαβάζει τις θερμοκρασίες διαφόρων ημερών του μήνα,
! έστω 30, και υπολογίζει τη μέση θερμοκρασία του μήνα.
!
!    ΠΡΟΓΡΑΜΜΑ Θερμοκρασίες
!    ΜΕΤΑΒΛΗΤΕΣ
!      ΠΡΑΓΜΑΤΙΚΕΣ : Θερμοκρασία[30], Μέση, Σύνολο
!      ΑΚΕΡΑΙΕΣ : i
!    ΑΡΧΗ
!      Σύνολο <-- 0
!      ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30
!        ΓΡΑΨΕ 'Δώσε τη θερμοκρασία'
!        ΔΙΑΒΑΣΕ Θερμοκρασία[i]
!      Σύνολο <--  Σύνολο + Θερμοκρασία[i]
!      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
!      Μέση <-- Σύνολο/30
!      ΓΡΑΨΕ 'Μέση Θερμοκρασία',Μέση
!    ΤΕΛΟΣ ΠΡΟΓΡΑΜΜΑΤΟΣ
!
! α) Να γραφεί αντίστοιχο πρόγραμμα (που να κάνει τους ίδιους υπολογισμούς)
!    χωρίς τη χρήση πίνακα.                                                                                                              
! ===============================================================================================

ΠΡΟΓΡΑΜΜΑ Θερμοκρασίες_Α
ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ : Θερμοκρασία , Μέση, Σύνολο
  ΑΚΕΡΑΙΕΣ : i
ΑΡΧΗ
  Σύνολο <--  0
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30
    ΓΡΑΨΕ 'Δώσε τη θερμοκρασία'
    ΔΙΑΒΑΣΕ Θερμοκρασία
    Σύνολο <--  Σύνολο + Θερμοκρασία
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  Μέση <-- Σύνολο/30
  ΓΡΑΨΕ 'Μέση Θερμοκρασία:', Μέση
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters