Τώρα είναι Παρ 29 Μάιος 2020 02:34 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Δευτ 13 Μαρ 2006 06:13 pm 
Χωρίς σύνδεση

Εγγραφή: Σάβ 04 Μαρ 2006 03:33 pm
Δημοσιεύσεις: 9
Παράθεση:
ΑΥΤΟ ΤΟ ΠΡΟΓΡΑΜΜΑ ΔΕΧΕΤΑΙ ΕΝΑΝ ΑΠΟ ΤΟΥΣ ΤΡΕΙΣ ΤΥΠΟΥΣ ΠΡΟ'Ι'ΟΝΤΩΝ ( x y z ) ΚΑΘΩΣ ΚΑΙ ΤΗΝ ΤΙΜΗ ΣΤΗΝ ΟΠΟΙΑ ΠΟΛΗΘΗΚΑΝ ΚΑΙ ΕΜΦΑΝΙΖΕΙ ΤΗΝ ΠΡΟΜΗΘΕΙΑ ΠΟΥ ΘΑ ΛΑΒΟΥΝ ΟΙ ΜΕΣΑΖΟΝΤΕΣ (ΚΛΙΜΑΚΩΤΑ)




Syntax: [ Download ] [ Hide ]

πρόγραμμα thema3

μεταβλητές
  πραγματικές:tim,pos1,pos2,pos3
  χαρακτήρες:tip

αρχή
  αρχή_επανάληψης
    γράψε 'dose ton tipo tou proiontos x,z,y'
    διάβασε tip
  μέχρις_ότου (tip='x') ή (tip='y') ή (tip='z')
  γράψε 'dose tin timh stin opoia polithike'
  διάβασε tim
  αν tim<=5000 τότε
    αν tip='x' τότε
      pos1 <-- 0
    αλλιώς_αν tip='y' τότε
      pos1 <-- tim*0.02
    αλλιώς_αν tip='z' τότε
      pos1 <-- tim*0.04
    τέλος_αν
  αλλιώς
    αν tip='x' τότε
      pos2 <-- (tim-5000)*0.05
      pos3 <-- (tim-10000)*0.1

    αλλιώς_αν tip='y' τότε

      pos1 <-- 5000*0.02
      pos2 <-- (tim-5000)*0.06
      pos3 <-- (tim-10000)*0.07

    αλλιώς
      pos1 <-- 5000*0.04
      pos2 <-- (tim-5000)*0.06
      pos3 <-- (tim-10000)*0.08
    τέλος_αν
    αν pos2<0  τότε pos2 <-- 0
    τέλος_αν
    αν  pos3<0 τότε pos3 <-- 0
    τέλος_αν
  τέλος_αν
  γράψε 'i promitheia pou tha dothei einai  ',pos1+pos2+pos3

τέλος_προγράμματος



 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters