Τώρα είναι Δευτ 26 Αύγ 2019 07:31 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Πέμ 12 Απρ 2007 03:37 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 12 Οκτ 2003 01:52 am
Δημοσιεύσεις: 189
Τοποθεσία: ΝΙΚΑΙΑ - ΠΕΙΡΑΙΑΣ
Syntax: [ Download ] [ Hide ]
! ===============================================================================================
! ΕΣΠΕΡΙΝΟ - ΙΟΥΛΙΟΣ 2004 - ΘΕΜΑ 2
! ===============================================================================================
! Δίνεται το ακόλουθο διάγραμμα ροής:
!
!
!  1. Να μετατρέψετε το παραπάνω διάγραμμα ροής σε πρόγραμμα που να περιλαμβάνει:
!       α. Τμήμα δηλώσεων.
!       β. Κύριο μέρος.
!  2. Να γράψετε τον πίνακα τιμών των μεταβλητών Α, Β και S, αν ως αρχικές τιμές δοθούν
!     Α = 15 και Β = 20.
! ===============================================================================================

ΠΡΟΓΡΑΜΜΑ ΕΣ_2004_07_2
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ : a , b , s
ΑΡΧΗ
  ΓΡΑΨΕ 'Δώσε την τιμή του Α'
  ΔΙΑΒΑΣΕ a
  ΓΡΑΨΕ 'Δώσε την τιμή του Β'
  ΔΙΑΒΑΣΕ b
  s <-- 0
  ΟΣΟ b > 0 ΕΠΑΝΑΛΑΒΕ                  
    ΓΡΑΨΕ ' -------------'                                                
    ΑΝ b MOD 2 = 1 ΤΟΤΕ
      s <-- s + a
    ΤΕΛΟΣ_ΑΝ
    a <-- a * 2
    b <-- b DIV 2
    ΓΡΑΨΕ '    Α  =' , a            ! ΟΙ ΕΝΤΟΛΕΣ ΑΥΤΕΣ ΔΕΝ ΥΠΑΡΧΟΥΝ ΣΤΟ ΔΙΑΓΡΑΜΜΑ ΡΟΗΣ.
    ΓΡΑΨΕ '    Β  =' , b            ! ΠΡΟΣΤΕΘΗΚΑΝ ΓΙΑ ΝΑ ΕΜΦΑΝΙΣΤΟΥΝ ΟΙ ΤΙΜΕΣ ΤΩΝ Α , Β
    ΓΡΑΨΕ '    S  =' , s            ! ΚΑΙ S.
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ ' -------------'
  ΓΡΑΨΕ '    S  =' , s
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters