Τώρα είναι Δευτ 18 Φεβ 2019 10:45 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Πέμ 12 Απρ 2007 03:31 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 12 Οκτ 2003 01:52 am
Δημοσιεύσεις: 189
Τοποθεσία: ΝΙΚΑΙΑ - ΠΕΙΡΑΙΑΣ
Syntax: [ Download ] [ Hide ]
! ===============================================================================================
! ΕΣΠΕΡΙΝΟ - ΙΟΥΛΙΟΣ 2004 - ΘΕΜΑ 4
! ===============================================================================================
! Σε ένα διαγωνισμό συμμετέχουν 5000 διαγωνιζόμενοι και εξετάζονται σε δυο μαθήματα.
! Να γράψετε αλγόριθμο που
!  1. να διαβάζει και να καταχωρίζει σε κατάλληλους πίνακες για κάθε διαγωνιζόμενο τον αριθμό
!     μητρώου, το ονοματεπώνυμο και τους βαθμούς που πήρε στα δυο μαθήματα.
!     Οι αριθμοί μητρώου θεωρούνται μοναδικοί.
!     Η βαθμολογική κλίμακα είναι από 0 έως και 100.
!  2. να εμφανίζει κατάσταση επιτυχόντων με την εξής μορφή :
!        Αριθ. Μητρώου :
!        Ονοματεπώνυμο :
!        Μέσος Όρος :
!    Επιτυχών θεωρείται ότι είναι αυτός που έχει μέσο όρο βαθμολογίας μεγαλύτερο ή ίσο του 60.
!  3. να διαβάζει έναν αριθμό μητρώου και
!     α. σε περίπτωση που ο αριθμός μητρώου είναι καταχωρισμένος στον πίνακα, να εμφανίζεται
!        ο αριθμός μητρώου, το ονοματεπώνυμο, ο μέσος όρος βαθμολογίας και η ένδειξη
!        "ΕΠΙΤΥΧΩΝ" ή "ΑΠΟΤΥΧΩΝ", ανάλογα με τον μέσο όρο.
!     β. σε περίπτωση που ο αριθμός μητρώου δεν είναι καταχωρισμένος στον πίνακα, να εμφανίζεται
!        το μήνυμα "Ο αριθμός μητρώου δεν αντιστοιχεί σε διαγωνιζόμενο".
!
! Σημείωση: Δεν απαιτείται έλεγχος εγκυρότητας καταχώρισης δεδομένων.
! ===============================================================================================

ΠΡΟΓΡΑΜΜΑ ΕΣ_2004_07_4
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ : i , k , index[500]
  ΠΡΑΓΜΑΤΙΚΕΣ: grade[500,2 ], mo
  ΧΑΡΑΚΤΗΡΕΣ: name[500]
  ΛΟΓΙΚΕΣ: flag
ΑΡΧΗ
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 500
    ΓΡΑΨΕ 'Δώσε τον αριθμό μητρώου του' , i , 'ου διαγωνιζομένου.'
    ΔΙΑΒΑΣΕ index[i]
    ΓΡΑΨΕ 'Δώσε το ονομά του.'
    ΔΙΑΒΑΣΕ name[i]
    ΓΡΑΨΕ 'Δώσε τους βαθμούς του στα δύο μαθήματα.'
    ΔΙΑΒΑΣΕ grade[i,1] , grade[i,2]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ 'Επιτυχόντες'
  ΓΡΑΨΕ '======================='
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 500
    mo <-- (grade[i,1] + grade[i,2])/2
    ΑΝ mo >= 60 ΤΟΤΕ
      ΓΡΑΨΕ 'Αριθ. Μητρώου : ' , index[i]
      ΓΡΑΨΕ 'Ονοματεπώνυμο : ' , name[i]
      ΓΡΑΨΕ 'Μέσος όρος    : ' , mo
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ 'Δώσε τον αριθμό μητρώου του διαγωνιζομένου που σε ενδιαφέρει.'
  ΔΙΑΒΑΣΕ k
  i <-- 1
  flag <-- ΨΕΥΔΗΣ
  ΟΣΟ flag = ΨΕΥΔΗΣ ΚΑΙ i <= 500 ΕΠΑΝΑΛΑΒΕ
    ΑΝ k = index[i] ΤΟΤΕ
      flag <-- ΑΛΗΘΗΣ
      mo <-- (grade[i,1] + grade[i,2])/2
      ΑΝ mo >= 60 ΤΟΤΕ
        ΓΡΑΨΕ 'ΕΠΙΤΥΧΩΝ'
      ΑΛΛΙΩΣ
        ΓΡΑΨΕ 'ΑΠΟΤΥΧΩΝ'
      ΤΕΛΟΣ_ΑΝ
    ΑΛΛΙΩΣ
      i <-- i + 1
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΑΝ flag = ΨΕΥΔΗΣ ΤΟΤΕ
    ΓΡΑΨΕ 'Ο αριθμός μητρώου δεν αντιστοιχεί σε διαγωνιζόμενο.'
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters