Τώρα είναι Δευτ 26 Αύγ 2019 08:04 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Πέμ 12 Απρ 2007 03:30 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 12 Οκτ 2003 01:52 am
Δημοσιεύσεις: 189
Τοποθεσία: ΝΙΚΑΙΑ - ΠΕΙΡΑΙΑΣ
Syntax: [ Download ] [ Hide ]
! ===============================================================================================
! ΗΜΕΡΗΣΙΟ - ΙΟΥΛΙΟΣ 2004 - ΘΕΜΑ 1Δ
! ===============================================================================================
! Δίνεται η παρακάτω αλληλουχία εντολών :
!    Α <-- x
!    Όσο Α < = y επανάλαβε
!       Α <- Α + z
!    Τέλος_επανάληψης
!
! Να γράψετε στο τετράδιο σας πόσες φορές εκτελείται η εντολή Α <-- Α + z για κάθε έναν από τους
! παρακάτω συνδυασμούς των τιμών των μεταβλητών x, y και ζ.
!    x =   0     y =  8    z =  3
!    x =   7     y = 10    z =  5
!    x = -10     y = -5    z = -1
!    x =  10     y =  5    z =  2
! ===============================================================================================

ΠΡΟΓΡΑΜΜΑ ΗΜ_2004_07_1Δ
ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ : x , y , z , A
ΑΡΧΗ
  ΓΡΑΨΕ 'x = 0 , y = 8 , z = 3'
  ΓΡΑΨΕ '====================='
  x <-- 0
  y <-- 8
  z <-- 3
  A <-- x
  ΟΣΟ A <= y ΕΠΑΝΑΛΑΒΕ
    A <-- A + z
    ΓΡΑΨΕ '  ***'
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ
  ΓΡΑΨΕ 'x = 7 , y = 10 , z = 5'
  ΓΡΑΨΕ '======================'
  x <-- 7
  y <-- 10
  z <-- 5
  A <-- x
  ΟΣΟ A <= y ΕΠΑΝΑΛΑΒΕ
    A <-- A + z
    ΓΡΑΨΕ '  ***'
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ                                                                                                                                            
  ΓΡΑΨΕ 'x = -10 , y = -5 , z = -1'
  ΓΡΑΨΕ '========================='
!  x <-- -10                  !
!  y <-- -5                   !  Με αυτές τις τιμές η επαναληπτική δομή δεν τελειώνει ποτέ.
!  z <-- -1                   !
!  Α <-- x                    !
!  ΟΣΟ Α <= y ΕΠΑΝΑΛΑΒΕ       !  Για να το διαπιστώσετε αρκεί να αφαιρέσετε τα θαυμαστικά.
!    Α <-- Α + z              !
!    ΓΡΑΨΕ '  ***'            !
!  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ           !
  ΓΡΑΨΕ 'Με αυτές τις τιμές δεν τερματίζεται η επαναληπτική διαδικασία.'
  ΓΡΑΨΕ
  ΓΡΑΨΕ 'x = 10 , y = 5 , z = 2'
  ΓΡΑΨΕ '======================'
  x <-- 10
  y <-- 5
  z <-- 2
  A <-- x
  ΟΣΟ A <= y ΕΠΑΝΑΛΑΒΕ
    A <-- A + z
    ΓΡΑΨΕ '  ***'      
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters